Erratic Idle - Nissan Forums : Nissan Forum
 
LinkBack Thread Tools Display Modes
  #1  
Old 07-11-2005, 04:34 AM
speedy266 speedy266 is offline
Registered User
 
Join Date: Sep 2003
Location: Canada
Posts: 44
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: 0 reviews
Erratic Idle

2002 Altima 2.5S has a werid idle. It has a high idle around 900rpm. In Park it'll be at 1100rpm, and if i tap the accelerator a tad it will start to increase on its own up unti 2000rpm, than drop down really fast to like 700rpm than quickly come back to 1100rpm. Seems like it has a fast idle when driving to, I can feel the downshifts when braking/slowing down. I got a Service engine soon light, so i pulled a code P0507, Idle speed control system for a high idle. To me it seems like the throttle plate needs to be lubed, but im sure thats not all, can anyone help?

crank it till it hz
Sponsored Links
Advertisement
 
  #2  
Old 07-11-2005, 03:38 PM
KeVQ35's Avatar
KeVQ35 KeVQ35 is online now
My little champion...
 
Join Date: Nov 2001
Location: Maryland
Posts: 4,916
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Thanks: 4
Thanked 14 Times in 11 Posts
iTrader: 3 reviews
Did you take your car in for service lately - throttle body cleaning? This occurs normally after throttle body cleaning has occured.

Had my throttle body cleaned and idle went up and light came on. They tried to blame it on the CAI I had installed.

I had that code go on since last year December 2004, and finally go off by itself maybe about 2-3 months ago...
  #3  
Old 07-11-2005, 05:05 PM
speedy266 speedy266 is offline
Registered User
 
Join Date: Sep 2003
Location: Canada
Posts: 44
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: 0 reviews
Yah i did do a throttle body cleaning and the light came on a couple days after, i reset it, hasnt come on again since but the idle is still all werid. Im thinking that while cleaning the carbon, some was pushed over onto a sensor or something, i wanna try fine cleaning it with a q-tip and maybe rubbing alcohal this time. Than lube all along the moving part. I think maybe opening the throttle plate manually is bad? Cause i didnt use alot of cleaner, and i sprayed it on a paper towel than cleaned.

crank it till it hz
  #4  
Old 07-12-2005, 01:23 AM
speedy266 speedy266 is offline
Registered User
 
Join Date: Sep 2003
Location: Canada
Posts: 44
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: 0 reviews
I did the Idle Air volume learning procedure and it idles as smooth as glass! Whew i was reading up on it and Nissan was suggesting new throttle bodies to some people who had the same problem i was getting scared cause its 700$, i was think theres no way a 700$ part goes bad from cleaning, theyd have some sort of prevention of that, otherwise thats just cheap. Hopefully nothing comes back. Thanks

crank it till it hz
  #5  
Old 07-01-2006, 05:43 AM
geo5599 geo5599 is offline
Registered User
 
Join Date: Jun 2006
Posts: 9
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: 0 reviews
man when i do the learning process my light doesnt blink

gio
  #6  
Old 07-01-2006, 05:44 AM
geo5599 geo5599 is offline
Registered User
 
Join Date: Jun 2006
Posts: 9
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: 0 reviews
and after you turn on and off 5 times do you quickly press the accelerater and release or calmly do it?

gio
  #7  
Old 07-01-2006, 06:58 AM
speedy266 speedy266 is offline
Registered User
 
Join Date: Sep 2003
Location: Canada
Posts: 44
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: 0 reviews
Hey i'll be glad to help you out with the process, i just dont know it off the top of my head how it goes. The speed of pressing and releasing should be about 1 second. So from the start of one full depression to a full release should be 1 second. Going to slow and the procedure wont work. But dont try and do it as fast as u can either. PM if you have any more questions.

crank it till it hz
  #8  
Old 07-11-2006, 04:47 AM
alibudiman alibudiman is offline
2much4U
 
Join Date: May 2005
Location: New York
Posts: 33
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: 0 reviews
hei..how many miles your car has, does it cover by the warranty?

  #9  
Old 07-12-2006, 02:32 PM
geo5599 geo5599 is offline
Registered User
 
Join Date: Jun 2006
Posts: 9
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: 0 reviews
its not under the warranty does anybody think this code p0420 would be the one that i need to really fix? could that be why the idle is high. the code is a (catalyst system efficiency below threshold) along with the p0507.
Sponsored Links
Advertisement
 
Reply

  Nissan Forums : Nissan Forum > Nissanclub.com Nissan - Infiniti Enthusiast Forums > NISSAN ALTIMA FORUMS > 2002-2006 Nissan Altima Forums > 2002-2006 Nissan Altima Discussion (2.5 & 3.5)

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Nissan Forums : Nissan Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


<

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome