Coolant Smell - Nissan Forums : Nissan Forum
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-21-2006, 10:31 PM
JOEZNISSAN's Avatar
JOEZNISSAN JOEZNISSAN is offline
Registered User
 
Join Date: Aug 2001
Location: SI NYC
Posts: 220
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: 0 reviews
Coolant Smell

I have a 2005 SE with 7500 miles on her. For the past couple of months Ive noticed a coolant smell after the car has been driven for a good 30 mins. I only smell it on the outside of the car, like when I open my drivers side door that hot air the car gives off from underneath. It will only last about 2 or 3 mins after I stop driving the car.I do not smell it in the cabin, vents, engine bay, or radiator area. I have no signs of leaks on the ground or white exhaust smoke and my heat works fine. I have not brought it into the dealer because I know if there is no physical signs of a leak they wont do a thing. Any ideas what this could be? thanks



2014 3.5SL Pearl White with Tech Package
Sponsored Links
Advertisement
 
  #2  
Old 01-28-2006, 02:57 AM
02VQ35 02VQ35 is offline
Registered User
 
Join Date: Dec 2002
Location: Griffith, IN
Posts: 768
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: 0 reviews
Take it in, they are well aware of the problem. The radiator is splitting usually on the driverside. Mine does that too, they can't find the problem though. Chris
  #3  
Old 01-28-2006, 03:31 AM
imptrlvr75's Avatar
imptrlvr75 imptrlvr75 is offline
Berk Powered
 
Join Date: Jan 2006
Location: Adrian, MI
Posts: 317
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: 0 reviews
Quote:
Originally Posted by 02VQ35
Take it in, they are well aware of the problem. The radiator is splitting usually on the driverside. Mine does that too, they can't find the problem though. Chris
From what I read it is the shitty plastic end tanks.

2002 Nissan Altima 3.5 SE Sheer Silver 5sp Manual
Berk V2 WAI INSTALLED (love it)
Mods on the way: AT Grounding Kit, Trenz billet grille
  #4  
Old 01-28-2006, 03:34 AM
02VQ35 02VQ35 is offline
Registered User
 
Join Date: Dec 2002
Location: Griffith, IN
Posts: 768
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: 0 reviews
Yup, thats whats splitting.
  #5  
Old 01-28-2006, 03:55 AM
Velicos's Avatar
Velicos Velicos is offline
Registered User
 
Join Date: Aug 2003
Posts: 2,371
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 3
Thanked 23 Times in 5 Posts
iTrader: 2 reviews
I've had two radiators go **POOF** due to the shitty plastic sections....

...damn you cheap Nissan engineering!

2009 Subaru Impreza WRX 5-Door
  #6  
Old 01-28-2006, 05:52 AM
cam2altima cam2altima is offline
Registered User
 
Join Date: Dec 2005
Location: hayward (bay area) california
Posts: 172
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: 0 reviews
hrmmm im goingto look into this.. i have just shy of 600 miles on my 06 se-r and i smell coolant when turning off the car or running for a while...

uhh ohh what did i get myself into here

06 sheer silver se-r:
HTML Code:
http://www.cardomain.com/ride/2318913/1
97 yota camry: my camry
  #7  
Old 02-03-2006, 11:00 PM
JOEZNISSAN's Avatar
JOEZNISSAN JOEZNISSAN is offline
Registered User
 
Join Date: Aug 2001
Location: SI NYC
Posts: 220
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: 0 reviews
Quote:
Originally Posted by imptrlvr75
From what I read it is the shitty plastic end tanks.

Thanks for the replies, is the end tank part of the radiator itself?..When I have some time Im gonna make an appt with the dealer to have it checked, but Ive smelt it for a good 3 months and it hasnt gotten worse and my level seems to be the same.



2014 3.5SL Pearl White with Tech Package
  #8  
Old 02-04-2006, 12:44 AM
imptrlvr75's Avatar
imptrlvr75 imptrlvr75 is offline
Berk Powered
 
Join Date: Jan 2006
Location: Adrian, MI
Posts: 317
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: 0 reviews
Yeah, they are attached to the top and bottom. Without them the radiator would not be sealed.

2002 Nissan Altima 3.5 SE Sheer Silver 5sp Manual
Berk V2 WAI INSTALLED (love it)
Mods on the way: AT Grounding Kit, Trenz billet grille
  #9  
Old 02-04-2006, 04:45 AM
thatchman1 thatchman1 is offline
changeyour|gameplan
 
Join Date: Nov 2002
Posts: 1,031
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 2 Times in 2 Posts
iTrader: 0 reviews
I had a radiator replaced on an 05 SE with less than 6K on it. There was a micro crack somewhere in it, and though I couldn't find the crack itself, I'd get some tiny white splatters on the black plastic. I could drive for weeks on end and never have to add any coolant, but I could smell it.

They ended up replacing the radiator and the problem went away. There were known supply issues with the radiators in some 03's? and 05's? or 02s and 05's, I don't remember... But the whole process was about 2 hours. The just hoist it, drop the radiator out from underneath, and the new one was in in no time.

Even as a detail person, I wasn't 100% convinced the radiator was cracked. The dealer offered to replace it, and I didn't complain, and for me that did end up fixing the issue.
  #10  
Old 03-03-2006, 07:21 PM
istungu's Avatar
istungu istungu is offline
2003 Altima SL
 
Join Date: Mar 2006
Location: BX, NYC
Posts: 150
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: 0 reviews
My ride is an 2003 and I'm having the same problem. Is this a recall matter whereas I can just bring it in and they fix it for free. Brought the car used so I'm sure its not under warranty anymore.
  #11  
Old 03-03-2006, 07:54 PM
virgilio7's Avatar
virgilio7 virgilio7 is offline
Banned
 
Join Date: Nov 2004
Location: Ft Lauderdale
Posts: 3,622
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: 0 reviews
no recall. is just the radiator. mine was leaking. i just replaced it.
the radiator was like 160
  #12  
Old 03-04-2006, 12:44 AM
thatchman1 thatchman1 is offline
changeyour|gameplan
 
Join Date: Nov 2002
Posts: 1,031
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 2 Times in 2 Posts
iTrader: 0 reviews
Did you get an OEM radiator, aftermarket, or used? That seems crazy cheap from what I've heard.

Did you lower it out from the bottom as the dealers do, or figure out some other way?

The dealer tried to tell me it would have been $700 if I had paid for it, so I'm interested to see if you got a crazy deal, they are crazy overpriced, or some combination of both...
  #13  
Old 03-04-2006, 02:10 AM
virgilio7's Avatar
virgilio7 virgilio7 is offline
Banned
 
Join Date: Nov 2004
Location: Ft Lauderdale
Posts: 3,622
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: 0 reviews
oem type made by koyo.
the one that is completely aluminum like the koyo one for the z cost 340. dealer is way overpriced.
  #14  
Old 03-08-2006, 03:41 PM
istungu's Avatar
istungu istungu is offline
2003 Altima SL
 
Join Date: Mar 2006
Location: BX, NYC
Posts: 150
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: 0 reviews
Any other way of fixing this without having to spend the ridiculous amount of money to have it replaced.
  #15  
Old 03-08-2006, 04:35 PM
virgilio7's Avatar
virgilio7 virgilio7 is offline
Banned
 
Join Date: Nov 2004
Location: Ft Lauderdale
Posts: 3,622
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: 0 reviews
bro. to replace a radiator shouldn't be much. max 100 bucks or so of labor.
Sponsored Links
Advertisement
 
Reply

  Nissan Forums : Nissan Forum > Nissanclub.com Nissan - Infiniti Enthusiast Forums > NISSAN ALTIMA FORUMS > 2002-2006 Nissan Altima Forums > 2002-2006 Nissan Altima Discussion (2.5 & 3.5)

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Nissan Forums : Nissan Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


<

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome