Shift lock solenoid control unit - Nissan Forums : Nissan Forum
 
LinkBack Thread Tools Display Modes
#1 Old 06-07-2009, 06:02 PM
Baba-T
 
lilteelaw22's Avatar
 
Join Date: Aug 2007
Location: Houston, TX
Posts: 73
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: 0 reviews
(Thread Starter)
Shift lock solenoid control unit

Before going to church today I got in my car turned it on and tried to shift (automatic) from park into reverse but the shifter refused to move. I then noticed that I longer heard the click sound I would usually hear when I pressed on the brake to shift the car from gear to gear. Im quite certain its the Shift Lock Solenoid. Has anyone had this problem. Also how do you replace it?
thanks for any input....
lilteelaw22 is offline  
Sponsored Links
Advertisement
 
#2 Old 06-07-2009, 07:14 PM
Baba-T
 
lilteelaw22's Avatar
 
Join Date: Aug 2007
Location: Houston, TX
Posts: 73
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: 0 reviews
(Thread Starter)
Nevermind got it fixed it was a blown fuse....
Thank God.......
lilteelaw22 is offline  
#3 Old 06-26-2009, 08:11 AM
Registered User
 
Join Date: Jun 2009
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: 0 reviews
my altima is doin that now and i can't get it out of park what fuse.
altimatnn is offline  
#4 Old 06-26-2009, 11:00 PM
Registered User
 
1Lil C's Avatar
 
Join Date: Sep 2007
Location: Far North Dallas, TX
Posts: 79
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: 0 reviews
Quote:
Originally Posted by altimatnn View Post
my altima is doin that now and i can't get it out of park what fuse.
Just like, lilteelaw22's Alti, try checking your fuse.(inside ones) I belive it was was the one labeled "Electric..." Can't remember. The same thing happened to me as far as the shifter. My interior indicators would not come on as well. Good luck.
1Lil C is offline  
#5 Old 06-29-2009, 04:42 AM
Registered User
 
Join Date: Jun 2009
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: 0 reviews
shifter stuck

I just wanted to add a link to my post. I have a similar problem but I do not believe it is the fuse. I have posted a link to a PDF in my post that has many pictures detailing how I took apart the center console, the buttons that detect that you have pressed the brake and the little motor and button at the shifter that block you from shifting. Hope this helps someone like me that haven't taken anything like this apart before or has a hard time visualizing what is going on with this problem.

I believe the cause of mine is either the button at the pedal or the little motor at the shifter. I should find out tomorrow.

http://www.nissanclub.com/forums/200...ml#post3788446

End the end my solution was to use a zip tie to keep the switch by the shifter depressed. The Nissan store only sells the entire shifter unit the little motor thing that depresses the switch does not come off as a separate part. That entire assembly is about 400 bucks. So the car will shift without my foot on the break but I have 400 more in my pocket.

Last edited by rhdowns; 11-24-2009 at 03:56 PM.
rhdowns is offline  
#6 Old 10-02-2009, 05:41 PM
Shift_me
 
Join Date: Feb 2003
Location: PA
Posts: 440
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: 0 reviews
Quote:
Originally Posted by 1Lil C View Post
Just like, lilteelaw22's Alti, try checking your fuse.(inside ones) I belive it was was the one labeled "Electric..." Can't remember. The same thing happened to me as far as the shifter. My interior indicators would not come on as well. Good luck.
Just to add on- I was messing out with interior lights yesterday and in the process my screw driver touched the bulb contacts, shorted, and blew a fuse. My shifter would not come out of park. First check eletronic fuse, if not then check all others too. Most likely a fuse that controls the unit which tells you put your foot on the brake.
yar786 is offline  
#7 Old 10-02-2009, 06:40 PM
FERRARI SLAYER
 
Genocide's Avatar
 
Join Date: Jul 2009
Posts: 973
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 1
Thanked 0 Times in 0 Posts
iTrader: 0 reviews
i did the same thing with the screwdriver on my vanity lights...blew a fuse replaced it n they still dont work alon with my interior indicator...and the shift lock is stuck..i jus live with it though its ot a big deal....i rigged up a little piece to put in the shift lock hole n now it works fine

Gold 02' Altima 2.5

PERFORMANCE MODS. WHO CARES ABOUT THE REST RIGHT?:
Tsudo Catback
2J Racing Underdriven PS pulley
Lightweight crank pulley
Cut balance shaft chain
Custom SRI
2J Racing Intake Manifold
Stillen Header
Stillen Catless Midpipe
TB Bypass
Indexed NGK Iridiums





Genocide is offline  
#8 Old 10-02-2009, 10:33 PM
Registered User
 
Join Date: Aug 2009
Posts: 574
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 2 Times in 1 Post
iTrader: 0 reviews
I've always thought that that weird solenoid "click" when you step on and let off the brake pedal when stopped (or almost stopped) was one of the oddest things about the Altima.

Never had another car do that, very strange. But I guess its better than not being able to put it in Drive!

Last edited by trooplewis; 10-02-2009 at 10:53 PM.
trooplewis is offline  
#9 Old 10-02-2009, 11:27 PM
Shift_me
 
Join Date: Feb 2003
Location: PA
Posts: 440
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: 0 reviews
Hey guys I have a solution for you. I went out to my car and found the fuse responsible for the shifter solenoid. The same fuse can also cut off power to the map light, dome light, the beeping sound when you leave the keys in the ignition and the doors are open.

Fuse is called "Battery saver" was blown on my car. This is located inside of the car to the left of the steering wheel near hood latch. Sorry about the dark picture but its all I have at the moment. Hope this helps.



To the guy stating the sound is weird, yes its weird but if you think about other older cars you had to press in a button on the shifter before you could move it. Sound doesn't bother me as much as it used to.

Last edited by yar786; 10-02-2009 at 11:32 PM.
yar786 is offline  
Sponsored Links
Advertisement
 
Reply

  Nissan Forums : Nissan Forum > Nissanclub.com Nissan - Infiniti Enthusiast Forums > NISSAN ALTIMA FORUMS > 2002-2006 Nissan Altima Forums > 2002-2006 Nissan Altima Discussion (2.5 & 3.5)

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Nissan Forums : Nissan Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


<

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome