Clicking noise when Turning the Steering wheel - Nissan Forums : Nissan Forum
 
» Auto Insurance
» Featured Product
Wheel & Tire Center


NissanClub.com is the premier Nissan Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 06-18-2009, 05:36 PM
toocoo's Avatar
Roamer of the World
 
Join Date: Jun 2009
Location: Houston TX
Posts: 23
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: 0 reviews
Exclamation Clicking noise when Turning the Steering wheel

Hello all,

I am new to this board.

I just aquired a 2003 2.5S with 114K miles. It has a few problems most of which i've found answers for, except for this weird clicking noise that I hear when I turn the steering wheel. At first I thought I could have been the CV joints but it happens even when im at a dead stop and I turn the wheel. Which leads me to believe there is something wrong with the steering or power steering. Even when the engine is off it still makes the noise.

Any help is appreciated. This forum is great for nissan owners. I look foward to interacting with ya'll.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 06-18-2009, 11:35 PM
jimnolimit's Avatar
2010 2.5s Sedan
 
Join Date: Aug 2006
Location: brooklyn
Posts: 5,140
Thanks: 0
Thanked 1 Time in 1 Post
iTrader: 0 reviews
if its not the CV joint , it could be the joint in the steering column that leads to the steering rack .
__________________
MY AUTO BLOG (COMPLETE WITH INSTALLS).

http://jimsautoeverything.blogspot.com/
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 06-19-2009, 12:22 AM
SE-R Tuner's Avatar
Code Red
 
Join Date: Jul 2008
Location: Ohio
Posts: 525
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: 0 reviews
Could be something in the steering column but I wouldnt think so. Check your lug nuts for your wheels to make sure they are not loose, other then that I would have to see, feel, or hear it...
__________________
^Not your average 4-door^

No tune 5 A/T
60' 2.03
13.91 @102.37
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 06-19-2009, 12:28 AM
toocoo's Avatar
Roamer of the World
 
Join Date: Jun 2009
Location: Houston TX
Posts: 23
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: 0 reviews
well I say that its not the CV joints but i had an acura in the past that had a bad CV joint and its a totally different sound. Im gonna go see if i can take a small video of the noise. But im thinking like jimnolimit that it might be something connected to the steering.
Reply With Quote Quick reply to this message
  #5 (permalink)  
Old 06-19-2009, 12:30 AM
jkgultimate's Avatar
Registered User
 
Join Date: Jun 2007
Posts: 2,121
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: 0 reviews
Quote:
Originally Posted by toocoo View Post
Hello all,

I am new to this board.

I just aquired a 2003 2.5S with 114K miles. It has a few problems most of which i've found answers for, except for this weird clicking noise that I hear when I turn the steering wheel. At first I thought I could have been the CV joints but it happens even when im at a dead stop and I turn the wheel. Which leads me to believe there is something wrong with the steering or power steering. Even when the engine is off it still makes the noise.

Any help is appreciated. This forum is great for nissan owners. I look foward to interacting with ya'll.
Your power steering will make a REALLY loud whining noise so its not that. Check all your front stabilizing links or check even for broken ones.

If you don't see the problem there, check up your front end and wiggle the tire by grabbing the tire from opposite ends.

First put your hands on top and bottom and give it a wiggle and then put your hands across the tire and give it a wiggle. If there is play up and down, you have a bad ball joint.

If you have a wiggle side to side, your tie-ends are no good. It could be either the inner or outter tie-rod end so check both parts for movement when you get under the car. I would recommend someone doing those wiggles and you check for any unusual play.
__________________
2007 Altima 3.5 SE 6MT Bone Stock! 14.180@100.16 MPH (70F)


----Dynapack: 242WHP, 217.5TQ ---Dynojet: 266WHP, 239 TQ (Fujita intake only).


1995 Eagle Talon TSi (Modded) 12.21@116.47 MPH (70F)

AS OF AUGUST: 11.2@129 MPH (85F) NEW SETUP.

1998 Lexus GS400 5At (BONE STOCK) 14.36@97.21 mph
Reply With Quote Quick reply to this message
  #6 (permalink)  
Old 06-19-2009, 12:38 AM
aviatorwes's Avatar
SHIFT_excitement
 
Join Date: Jan 2008
Location: Lemoore CA
Posts: 714
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: 0 reviews
Did you notice the car stray from side to side while holding the wheel straight when you were driving it? If so then its probably a bad ball joint or tie rod like stated above.
__________________

Injen CAI, Unorthodox crank pulley, VIAS delete, B&M short shifter, APR front strut bar, OBX headers, NISMO Y-pipe, Straight pipe to Magnaflow mufflers, Wilwood BBK, NGK plugs.
Reply With Quote Quick reply to this message
  #7 (permalink)  
Old 06-19-2009, 01:38 AM
SE-R Tuner's Avatar
Code Red
 
Join Date: Jul 2008
Location: Ohio
Posts: 525
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: 0 reviews
Lol oops im stupid, forgot all about ball joints and tie rods. But if it was a ball joint you would hear more of a popping noise. Just jack the car up rotate and wiggle the tires and stuff and you should be able to see or feel whats going on. Also look for any broken boots and seals ie. if your tie rods boot is sliced or cracked chances are that would be your problem...
Reply With Quote Quick reply to this message
  #8 (permalink)  
Old 06-19-2009, 01:45 AM
Registered User
 
Join Date: Sep 2006
Location: NYC
Posts: 808
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: 0 reviews
i have the same problem too. i hear a "click" when i turn the steering wheel half way around. i thought it was a loose screw or something holding the steering column cover but i'm going to have to look into this.

sorry for hijacking but sometimes, i would hear one of my tires wobble when i drive over uneven roads...does this have to do with the ball joint/tie rod or is it just a bad wheel bearing?
__________________

Performance: | AEM CAI | Magnaflow resonator-Stock pipes-Magnaflow 14862 muffler | XS Header
Cosmetics: | 35% tint | OEM sidesills | OEM splash guards | OEM Fogs | McCulloch 6k HIDS | Raptor 6k Fog HIDS | LEDS | BT footwell LED kit | BT underhood LED kit | SE-R tails | AT S2 grille | Debadged | Red calipers | DIY Blacked out headlights | RL BTD |
Wheels/Suspension: | 05/06 SE Alloys-Yoko Avid TRZ | RL FTSB | Stillen RSB | RL REL |

Last edited by pbwillz; 06-19-2009 at 01:51 AM.
Reply With Quote Quick reply to this message
  #9 (permalink)  
Old 06-19-2009, 02:30 AM
toocoo's Avatar
Roamer of the World
 
Join Date: Jun 2009
Location: Houston TX
Posts: 23
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: 0 reviews
Quote:
Originally Posted by pbwillz View Post
i have the same problem too. i hear a "click" when i turn the steering wheel half way around. i thought it was a loose screw or something holding the steering column cover but i'm going to have to look into this.

sorry for hijacking but sometimes, i would hear one of my tires wobble when i drive over uneven roads...does this have to do with the ball joint/tie rod or is it just a bad wheel bearing?
I just took a quick trip down the street and im hearing a cluncking noise from my front wheel.

Im thinking that we could be having the same issue. This weekend im definately gettin the front wheel off and seeing whats the deal. Ill keep everyone posted.
Reply With Quote Quick reply to this message
  #10 (permalink)  
Old 06-19-2009, 04:21 AM
SE-R Tuner's Avatar
Code Red
 
Join Date: Jul 2008
Location: Ohio
Posts: 525
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: 0 reviews
If there is clunking then it could be a ball joint and you shouldnt wait to look at it! My friends car rolled because his ball joint popped out when he was doing a lane change on the highway and my wifes popped out and almost cause some major damage. Anyway poping or clunking sounds like a ball joint to me...

As for the other guy experiencing "wobble" that sounds like a wheel bearing to me and also isnt good, wouldnt put that off either. Jack the car up and spin the wheel. If it wobbles or you can make it wobble chances are its a wheel bearing...
Reply With Quote Quick reply to this message
  #11 (permalink)  
Old 06-19-2009, 04:43 AM
200hpAltima's Avatar
Ctrl-F Yourself
 
Join Date: Sep 2007
Location: Rochester, NY
Posts: 5,252
Thanks: 41
Thanked 23 Times in 17 Posts
iTrader: 0 reviews
If it turns out to be none of these. Check the steering rack. Not the column or the pump but the rack. Ponticas have a major problem with their racks (tehehe play on words) and they click when you turn the wheel either way.
__________________
E-Racings Front|Tint|Tsudo Catback|Verde 18's|Woodgrain Dash Kit|Tinted Tails|Vinyl Behind Mirrors| Too Much to List!
DIY LED Tursignals In Mirrors|DIY Projector Retrofit|What You Need to Convert to OEM HID|Nissan Factory Service Manual Here|How To Check/Clear SES Codes HERE|Upgrading The Stock Halogen Headlights|Detailed Description of HID and Angel Eyes

BEST IN CLASS AT 2009 CANAL DAYS CAR SHOW!


Quote:
Originally Posted by KeVQ35 View Post
Your car is like the ugly chick that all the guys look at in disbelief, but she tells all her girlfriends that guys are constantly checking her out.
Reply With Quote Quick reply to this message
  #12 (permalink)  
Old 06-19-2009, 12:49 PM
toocoo's Avatar
Roamer of the World
 
Join Date: Jun 2009
Location: Houston TX
Posts: 23
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: 0 reviews
Thanks everyone for thier insight...I have a .2 mile commute to work so im not too concerned with it popping out on me. But tomorrow im taking it to my lil tool shed at my dads fab shop and gettin that wheel off and taking a good look at whats going on...ill be sure to take pictures and post up what the problem was.
Reply With Quote Quick reply to this message
  #13 (permalink)  
Old 06-19-2009, 09:02 PM
aviatorwes's Avatar
SHIFT_excitement
 
Join Date: Jan 2008
Location: Lemoore CA
Posts: 714
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: 0 reviews
Quote:
Originally Posted by toocoo View Post
I just took a quick trip down the street and im hearing a cluncking noise from my front wheel.

Im thinking that we could be having the same issue. This weekend im definately gettin the front wheel off and seeing whats the deal. Ill keep everyone posted.
This sounds like it could be a bad CV joint. If it clicks when you turn then thats probably what that is.
Reply With Quote Quick reply to this message
  #14 (permalink)  
Old 06-21-2009, 04:29 AM
toocoo's Avatar
Roamer of the World
 
Join Date: Jun 2009
Location: Houston TX
Posts: 23
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: 0 reviews
Well had a father in law take a look at it (hes a mechanic). and my struts and shocks are shot!. and my 2 front motor mounts are crapped out. He said my CV joints and boots are fine and he doesn't see any problems with them. So as i fix those problems ill update and let yall know if it took care of the clicking noise.
Reply With Quote Quick reply to this message
  #15 (permalink)  
Old 06-21-2009, 09:39 AM
jimnolimit's Avatar
2010 2.5s Sedan
 
Join Date: Aug 2006
Location: brooklyn
Posts: 5,140
Thanks: 0
Thanked 1 Time in 1 Post
iTrader: 0 reviews
Quote:
Originally Posted by toocoo View Post
Well had a father in law take a look at it (hes a mechanic). and my struts and shocks are shot!. and my 2 front motor mounts are crapped out. He said my CV joints and boots are fine and he doesn't see any problems with them. So as i fix those problems ill update and let yall know if it took care of the clicking noise.
if he said your struts are shot and it makes a clicking noise when you turn , it sounds like your top strut mounts are bad .
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  Nissan Forums : Nissan Forum > Nissanclub.com Nissan - Infiniti Enthusiast Forums > NISSAN ALTIMA FORUMS > 2002-2006 Nissan Altima Forums > 2002-2006 Nissan Altima Discussion (2.5 & 3.5)


Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Nissan Forums : Nissan Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT. The time now is 03:45 PM.


Powered by vBulletin®. Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.3.2
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.