MAF (Mass Air Flow) for 2002 Altima 3.5 SE - Nissan Forums : Nissan Forum
 
» Auto Insurance
» Featured Product
Wheel & Tire Center


NissanClub.com is the premier Nissan Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 03-19-2010, 09:27 PM
3.5AltimaNJ02's Avatar
02 3.5 owner since 2004
 
Join Date: Apr 2004
Location: NJ
Posts: 104
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: 0 reviews
Question MAF (Mass Air Flow) for 2002 Altima 3.5 SE

I took my car to the dealership because I was having poor acceleration (choking) issues. The car moves in and out of gears fine. It is when I try to STEP on it, that the car gets bogged down and doesn't want to kick into action. Dealer charged me $97 to hook it up to their computer and said they still don't know the problem. They said the front and rear O2 sensors were giving bad readings, but would need to charge me another $130 just to see/check if it was one of the Pre-Cats. I told them goodbye.

I took my car to Meineke to get the exhaust checked out. They ran some exhaust tests and said they believe the exhaust is fine, but think it could possibly be the MAF. The only issue is that they want to charge me $550 parts/labor. It is pretty expensive since I could get it for way cheaper and install myself, but they said if it isn't the MAF causing the problem, they will not charge me for it.

I just spent $500 on replacing the front driverside wheel hub and bearing, plus I need new tires. Should I just suck it up and give them the $550 or just buy an $80 MAF off of ebay and cross my fingers that it is actually the MAF?

Air Mass Flow Sensor Nissan 02 03 Altima Sentra MAF NEW : eBay Motors (item 390168988008 end time Apr-11-10 14:30:00 PDT)

or

02 2003 Nissan Altima 2.5L 3.5L Mass Air Flow Meter MAF : eBay Motors (item 350272781551 end time Mar-30-10 11:57:38 PDT)

Thanks.
__________________
2002 Nissan Altima 3.5 SE Super Black
*Black Leather Interior
*Moon Roof
*Autodim
*6 CD Bose Stereo System
*Stainless Steel Brake Lines
*50% Black Onyx Tint All Around
*Brushed Aluminum Dash Kit
*Custom Enterprise Rear Sway Bar
*Continental ExtremeContact DWS Tires (Ultra High Performance All-Season)
*MP3 Hookup
*Viper Remote Starter

Last edited by 3.5AltimaNJ02; 03-19-2010 at 10:05 PM.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 03-20-2010, 12:41 AM
Registered User
 
Join Date: Dec 2006
Location: BRooKLN
Posts: 1,036
Thanks: 1
Thanked 0 Times in 0 Posts
iTrader: 1 reviews
sounds pretty much same problems i had and it was the maf, go to autozone and have them hook it up to a reader, also try MAF cleaner sometimes it helps but very rare
__________________
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 03-20-2010, 01:07 AM
3.5AltimaNJ02's Avatar
02 3.5 owner since 2004
 
Join Date: Apr 2004
Location: NJ
Posts: 104
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: 0 reviews
Isn't a reader only good if the car is showing an SES light? My car isn't showing the SES light.

You think it's worth it to just buy one of the ebay MAF's?
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 03-20-2010, 02:08 AM
Registered User
 
Join Date: Dec 2009
Posts: 317
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: 0 reviews
Quote:
Originally Posted by 3.5AltimaNJ02 View Post
Isn't a reader only good if the car is showing an SES light? My car isn't showing the SES light.

You think it's worth it to just buy one of the ebay MAF's?
I have a computer serial-usb scanner/reader. (ScanXL) It will only tell you codes if a light is or has recently been on. It will, however, allow you to see some other information such as the airflow rate, spark advance, fuel flow rate, engine rpm, etc... (they're called PID's)

You can use this to help you troubleshoot your problems


Another option - go to autozone, buy the sensor, try it out. If it works, nice. If not - take it right back. It's not like you've damaged the product any.
Reply With Quote Quick reply to this message
  #5 (permalink)  
Old 03-20-2010, 02:26 AM
Blubird's Avatar
Low & Fast...
 
Join Date: Nov 2009
Location: The Wild Wild West!!!
Posts: 2,530
Thanks: 0
Thanked 3 Times in 3 Posts
iTrader: 0 reviews
If you have a bad MAF sensor... try unplugging it to see if it will throw a SES code. Its very strange if the MAF is bad but your not getting a SES code. And like the others mentioned... go to Autozone and see if they can find anything.
__________________


06 SE VQ 5spd sleeper ll...

Reply With Quote Quick reply to this message
  #6 (permalink)  
Old 03-28-2010, 10:11 PM
Registered User
 
Join Date: Feb 2005
Posts: 305
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: 0 reviews
If your problem is a blown MAF, the fix is using an 03 G35 automatic MAF. The manual's (IIRC) were avoided for some reason.

Have you tried a junkyard? They are a great source for OEM parts. I use car-part.com all the time for my car and my parents. You can haggle and find parts if you are willing to pay a little for shipping.

Unfortunately, cars are expensive to fix. If you haven't bought tire yet I went to Discount Tires, Wheels & ATV | Treadepot.com and got a great deal on some goodyear's. They run speicals and have the best prices on name brand tires I have seen yet.
Reply With Quote Quick reply to this message
  #7 (permalink)  
Old 03-29-2010, 12:52 PM
Mike James's Avatar
Altimer
 
Join Date: Jul 2009
Location: Guelph, Ontario
Posts: 1,018
Thanks: 1
Thanked 13 Times in 9 Posts
iTrader: 0 reviews
Quote:
Originally Posted by Swim100flyy View Post
Another option - go to autozone, buy the sensor, try it out. If it works, nice. If not - take it right back. It's not like you've damaged the product any.
Don't do this. They will have every right not to take it back. Installing electronics and trying to return it as new is a BIG no-no. And yes, they will be able to tell.
__________________

Altima traded for Odyssey
Current - 01 HIGHLANDER
Reply With Quote Quick reply to this message
  #8 (permalink)  
Old 03-30-2010, 01:22 AM
Registered User
 
Join Date: Aug 2001
Posts: 3,512
Thanks: 0
Thanked 5 Times in 5 Posts
iTrader: 0 reviews
This is a big issue w/the 5th and 5.5gen Maxies.....many have had similar experiences with the MAF being out of spec but not enough to throw a light. I'd hit up a local yard, car-part or perhaps Courtesy Nissan.

I don't know how similar/dissimilar the 5th gen Max and Altima MAF is but the Maxima guys get the 5th gen sensors for their '02-'03 Maximas for at or under $100 at the dealer and then swap the thermistor over.


Jeremy
Reply With Quote Quick reply to this message
  #9 (permalink)  
Old 04-21-2010, 04:11 PM
3.5AltimaNJ02's Avatar
02 3.5 owner since 2004
 
Join Date: Apr 2004
Location: NJ
Posts: 104
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: 0 reviews
The verdict is in....the Pre-Cat behind the engine is breaking up and clogging up my exhaust tube. I will need a new Pre-cat and need to have the exhaust tube hallowed out to fix the issue. Expensive, but at least I know what the problem is now and my car will run normal after it is fixed.
Reply With Quote Quick reply to this message
  #10 (permalink)  
Old 04-21-2010, 07:23 PM
Sh4dow_g's Avatar
Rav
 
Join Date: Feb 2010
Location: Toronto, Canada
Posts: 150
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: 0 reviews
hmmm maybe ur not into tuning ur Alti , but headers?
__________________
You ever try catching a shadow...? Exactly.
Reply With Quote Quick reply to this message
  #11 (permalink)  
Old 04-21-2010, 08:11 PM
3.5AltimaNJ02's Avatar
02 3.5 owner since 2004
 
Join Date: Apr 2004
Location: NJ
Posts: 104
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: 0 reviews
I probably won't consider headers, but I like how the car drives stock anyways and don't want to worry about O2 sensors and passing emissions, etc etc.
Reply With Quote Quick reply to this message
  #12 (permalink)  
Old 04-21-2010, 08:53 PM
jumper73's Avatar
Registered User
 
Join Date: Apr 2004
Location: New York
Posts: 900
Thanks: 32
Thanked 20 Times in 15 Posts
iTrader: 1 reviews
Taz's hi-flo cat can't come soon enough. I know my car (02' 3.5) is starting to have pre-cat issues and I'm hoping taz's product comes out sooner so that it doesn't damage my engine (if it hasn't already). Engine is consuming more oil between oil changes and I'm starting to get the dreaded sulfer smell every now and then.

http://www.nissanclub.com/forums/200...ect-today.html
__________________


Quote:
Originally Posted by djSER
a friend of mine installed a boost gauge on his WRX..

I was wondering if we have something like that for the SE-R..
Quote:
Originally Posted by 200hpAltima View Post
I was simply saying that flaming is a part of life and it is severely lacking in the forums that just run wild like Zebra. We have no lions to hunt the Zebra so they eat, fcuk, and multiply into an entire sections of retards with useless information.
Quote:
Originally Posted by CHiP View Post
If you consider the 65465418946516546 prices mentioned "clearly" stated, then it looks like the wannabe Lion was actually a Zebra all along.
Reply With Quote Quick reply to this message
  #13 (permalink)  
Old 04-21-2010, 09:17 PM
3.5AltimaNJ02's Avatar
02 3.5 owner since 2004
 
Join Date: Apr 2004
Location: NJ
Posts: 104
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: 0 reviews
Quote:
Originally Posted by jumper73 View Post
Taz's hi-flo cat can't come soon enough. I know my car (02' 3.5) is starting to have pre-cat issues and I'm hoping taz's product comes out sooner so that it doesn't damage my engine (if it hasn't already). Engine is consuming more oil between oil changes and I'm starting to get the dreaded sulfer smell every now and then.

http://www.nissanclub.com/forums/200...ect-today.html
Yeah, I'm subscribed to Taz's Hi-Flo Cat Project Thread, but unfortunately, his product isn't ready and I need the work done now.

I never had any oil consumption issues...knock on wood...only acceleration problems.

Last edited by 3.5AltimaNJ02; 04-21-2010 at 09:20 PM.
Reply With Quote Quick reply to this message
  #14 (permalink)  
Old 04-27-2010, 04:54 AM
Registered User
 
Join Date: Apr 2010
Posts: 69
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: 0 reviews
only 3.5L engine will work with AM600. the QR25DE only fit with 8j000
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  Nissan Forums : Nissan Forum > Nissanclub.com Nissan - Infiniti Enthusiast Forums > NISSAN ALTIMA FORUMS > 2002-2006 Nissan Altima Forums > 2002-2006 Nissan Altima Discussion (2.5 & 3.5)


Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Nissan Forums : Nissan Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT. The time now is 06:57 PM.


Powered by vBulletin®. Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.3.2
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.