2003 Altima won't accelerate when in drive - Nissan Forums : Nissan Forum
 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 03-18-2012, 03:30 AM Thread Starter
Registered User
 
Join Date: Mar 2012
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: 0 reviews
(Thread Starter)
2003 Altima won't accelerate when in drive

Some weird things going on with my Altima. As I came to a stop off the freeway everything was fine. I tried to turn right but I wasn't able to accelerate. It was pretty much at idle rpms. I pulled the car over. I put it in park and was able to rev the engines...same thing worked for reverse and neutral. So I tried drive again, but still no acceleration. Turned off the engine and tried to start...but it wouldn't start. Dead battery...however, it was a new battery installed yesterday. The battery was replaced because the same thing happened and the new battery solved the problem..at least for a day. It appears that something is shorting out the battery...maybe the alternator? I'm puzzled to why I can't accelerate though...any help is appreciated.
thundermrt is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 05-17-2015, 12:26 AM
Registered User
 
Join Date: Apr 2015
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: 0 reviews
Based on what you said it means that there is not enough electricity for charging the battery. Therefore, the battery dies. We can conclude in the same way that the throttle and the fuel pump and ... cannot have enough electricity to function well also. If it was only your battery dead I would say it might be the connections on the battery and alternator or the ground connection that got dirty (or the fuses on the battery positive connection which can be found on that nissan altima model are blown).
BUT when you say it does not accelerate it means it cannot provide enough electricity for the car even when it is working (there is no need for battery anymore when the car is on since the alternator generates enough electricity to function the car).
All in all I would say it is your alternator that is not functioning well or some fuses in the fuse box that are interfering the alternators flow of electricity. BEFORE DOING ANYTHING check the driving belt and the pulleys and make sure they are working OK.
Would be happy if you let me know about the result.
Matt89 is offline  
post #3 of 4 Old 05-18-2015, 12:37 AM
'09 Altima SE Black 6MT
 
d0ugmac1's Avatar
 
Join Date: Jul 2013
Location: Salt Belt (SE Ontario)
Posts: 768
Mentioned: 5 Post(s)
Tagged: 0 Thread(s)
Quoted: 136 Post(s)
Thanks: 25
Thanked 70 Times in 68 Posts
iTrader: 0 reviews
Your alternator is dead and you need a new one. Sounds weird I know, check out my thread 'Alternator Insanity' in this forum. As it turns out the problem is too much electricity

This thread should sound *very* familiar.

Last edited by d0ugmac1; 05-18-2015 at 12:43 AM.
d0ugmac1 is online now  
post #4 of 4 Old 05-18-2015, 12:48 PM
never take it to the shop
 
1trucavalier's Avatar
 
Join Date: Apr 2006
Location: woodbridge, va
Posts: 2,081
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 112 Post(s)
Thanks: 5
Thanked 30 Times in 29 Posts
iTrader: 0 reviews
1trucavalier is online now  
Sponsored Links
Advertisement
 
Reply

  Nissan Forums : Nissan Forum > Nissanclub.com Nissan - Infiniti Enthusiast Forums > NISSAN ALTIMA FORUMS > 2002-2006 Nissan Altima Forums > 2002-2006 Nissan Altima Discussion (2.5 & 3.5)

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Nissan Forums : Nissan Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome