Help! various issues with car - Nissan Forums : Nissan Forum
 
LinkBack Thread Tools Display Modes
#1 Old 04-19-2012, 08:00 PM
Registered User
 
Join Date: Jan 2006
Posts: 292
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: 0 reviews
(Thread Starter)
Help! various issues with car

Hi All,

I have been doing lot of research and can't seem to find an exact answer if there is one out there to my issues.

Background- 2002 Altima SE 3.5 about 70K on it. (I barely drive since in NYC)

The old issue. I got a check engine light (2 months ago) and the car shut off on me while on the road. My mechanic checked it out and the codes were for the Cam sensor and the Knock sensor. Both cams and knock sensor changed and no more SES light.

The new issue. The other day I went to a dr. appoinment and the car did not want to start. It was not the battery as the lights and everything electrical worked and the car was cranking just not turning over. I called for road service and while I waited I did the procedure to check the engine but no codes so thats a good thing. I even hooked up my jumper in case it was the battery but nothing. After about 10 minutes I try to start and it did. As I was driving home on the highway I went to accelerate and the car seemed to be jerking at around 3K rpm so I let off the gas a bit and the jerking went away.

Now I read a lot of posts and threads and found some people having the starting issues and other the jerking but not really both and neither had real cause to the issue.

If you have had similar issue please let me know what you have done to resolve. Hope its not going to cost a lot because if not then time to trade in.

Thanks all
vladi77 is offline  
Sponsored Links
Advertisement
 
#2 Old 04-19-2012, 08:23 PM
Registered User
 
Join Date: Sep 2011
Posts: 209
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
iTrader: 0 reviews
I'd start by checking basic tune parts, spark plugs, fuel and air filters, vacuum leaks.
XLXR is offline  
#3 Old 04-19-2012, 08:45 PM
Registered User
 
Join Date: Jan 2006
Posts: 292
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: 0 reviews
(Thread Starter)
Thanks. The car might need a tune up. Dont think the plugs have been changed since 2004. Whats the best place to do a tune up? Dont want to go to the stealership and drop my pants. LOL
vladi77 is offline  
#4 Old 04-19-2012, 11:40 PM
Registered User
 
Ey3CoNz2's Avatar
 
Join Date: Dec 2008
Posts: 660
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 1
Thanked 4 Times in 4 Posts
iTrader: 0 reviews
It's your sensors again. It sounds exactly like when my sensors went. I get the feeling he didn't replace the sensors or if he did he replaced em with older faulty/generic brand sensors. Get the genuine nissan sensors and replace them yourself.

Ey3CoNz2 is offline  
#5 Old 04-24-2012, 03:32 PM
Registered User
 
Join Date: Jan 2006
Posts: 292
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: 0 reviews
(Thread Starter)
I trust the guy as he always gives me the old parts to keep and showed me the receipts from the dealership for the sensors. But I am not getting any codes as I was getting before he changed them. Kinda feels like a different problem.

But I think it does not matter anymore as I went car shopping this weekend and I will be jumping over to Audi and getting the new 2013 Q5 since the wife and I are expecting a baby soon.
vladi77 is offline  
#6 Old 04-24-2012, 03:47 PM
Registered User
 
Join Date: Apr 2012
Location: Houston, Tx
Posts: 17
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: 0 reviews
I have 2005 altima. The SES light is on since long. I recently got the ECM recall done and the light went off. Now the SES light is back after driving about 25 miles. Most likely its the catalytic convertor issue which is common on this model. The repair estimates are anywehere between $600 to $800. I dont have this kind of money to spend on the car. So being very clear to all here ans aksing that is there a way to simply switch off the light for ever? I tried all those trick to press the pedal etc and it does work but for only about 10 miles or so. The light comes back again. I just want to switch of the light forever (like remove the electric wire from the SES light ). Your help is very much appreciated. The car has run 138000 miles.
mohit.sarda is offline  
#7 Old 04-24-2012, 06:54 PM
Registered User
 
Join Date: Jan 2006
Posts: 292
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: 0 reviews
(Thread Starter)
I do not think you can take the light off forever unless you fix the problem. When you do the ECU reset it only resets the codes but if the engine/car notices the problem again it will set off the light.
vladi77 is offline  
#8 Old 05-04-2012, 01:19 AM
Registered User
 
Join Date: Jan 2006
Posts: 292
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: 0 reviews
(Thread Starter)
Update

I bought new sensors and watched as my guy changed them again and the codes did not go away. He recommended a friend at a shop nearby with a computer diagnostic so I take it to him and it shows it was an issue with the wiring harness. Car is now starting and running great. The car even had the airbag light on and the issue is now gone so I am hoping the car is gonna last me a few more years since it only has 70K miles so I would love to hit 100K. Will keep you updated if any other issues come up.
vladi77 is offline  
Sponsored Links
Advertisement
 
Reply

  Nissan Forums : Nissan Forum > Nissanclub.com Nissan - Infiniti Enthusiast Forums > NISSAN ALTIMA FORUMS > 2002-2006 Nissan Altima Forums > 2002-2006 Nissan Altima Discussion (2.5 & 3.5)

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Nissan Forums : Nissan Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


<

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome