Battery light and E-brake light on - Nissan Forums : Nissan Forum
 
LinkBack Thread Tools Display Modes
post #1 of 7 Old 11-06-2009, 12:04 AM Thread Starter
Registered User
 
Join Date: Sep 2009
Posts: 20
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: 0 reviews
(Thread Starter)
Battery light and E-brake light on

Hey guys, the battery light and e-brake light came on out of no where at the same time.

2 days later, the car dies while driving and my wife is stranded.

The battery seemed like the culprit so we replaced it. Car turns on but battery light is still on.

What could this mean?

Thanks guys.

duckJAI is offline  
Sponsored Links
Advertisement
 
post #2 of 7 Old 11-06-2009, 12:14 AM
Registered User
 
Join Date: Mar 2008
Location: Calgary, AB, Canada
Posts: 1,674
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 3 Times in 3 Posts
iTrader: 0 reviews
http://www.nissanclub.com/forums/200...ew-duo-me.html

03 Altima 3.5 SE 4AT

Berk V2 w/ Apexi ~ NWP VIAS Plate ~ Racingline FSTB, Grounding Kit, Battery Tie-down, Springs ~ KYB GR2's ~ UR Ultra Sc Pulley ~ BT Under hood and Trunk Lighting
duaner is offline  
post #3 of 7 Old 11-06-2009, 12:18 AM Thread Starter
Registered User
 
Join Date: Sep 2009
Posts: 20
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: 0 reviews
(Thread Starter)
Thanks for the reply.

I didn't think it would be the alternator since there was no alternator whine.

How much does an alternator cost from the dealer?
duckJAI is offline  
 
post #4 of 7 Old 11-06-2009, 12:23 AM Thread Starter
Registered User
 
Join Date: Sep 2009
Posts: 20
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: 0 reviews
(Thread Starter)
Also, when I tried to start the car with the old battery, I got the flicking sound effect.

Maybe I'll look into getting a reman alternator.
duckJAI is offline  
post #5 of 7 Old 11-06-2009, 10:46 PM
SilverBlack Guerrilla
 
MiDNiTe's Avatar
 
Join Date: Apr 2006
Location: Toronto
Posts: 881
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 2
Thanked 1 Time in 1 Post
Garage
iTrader: 4 reviews
It's the alternator. Had the exact same issue yesterday. replaced the alternator today and I'm back to normal. Also seems to have gotten rid of my AC belt vibrations


02 3.5 SE 6HLSD - Sheer Silver & Black - SilverBlack Guerrilla

| OBX Headers | MagnaFlow 16882 Catback Exhaust | Vias Deleted | NWP Intake Manifold Spacer Kit | 03 Maxima 6Spd HLSD Tranny | Exedy Stage 1 Clutch Kit | D2 Coilovers | 19"x8.5" Fast Hayaku (TE37 Reps)| Ebay Short Ram Intake | RL FSTB | 5% Tint | Depo SE-R Tails | Debadged | Chrome Trim Blackout | Audi A4 Projector Retro 4300k Low Beams & 6,000K Fogs | Pioneer 5900IB | Clifford 590.2 2-Way Alarm & Starter | LED Interior Light Conversion | C-Mod Mesh Grille | TWM Short Shift Adapter | SE-R Shift Knob |SE-R Lip Spoiler | 2* Timing Advance |

MiDNiTe is offline  
post #6 of 7 Old 02-11-2010, 01:03 AM
VQ Powered Grocery Getter
 
SE-R Altima Driver's Avatar
 
Join Date: Mar 2008
Location: Downingtown, PA
Posts: 1,581
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
iTrader: 0 reviews
This is nissan's warning the Alternator is going bad. Had the same thing on 2 different nissan cars and both times it was the alternator.
FYI.
Sorry to bump this old thread.


Nismo CAI
Nismo CAMS
Nismo CAT-back & exhaust
Nismo Radiator cap & Oil cap
SSIM Intake, NWP Spacers & VIAS Plate
Racingline Y-Pipe, Endlinks, Tower Strut and Battery BAR, Traction Bars
UpRev EMS
STS, S5 Grill, Fusion 12" Sub, Train Horns , 350 HP 385 Tq Dynotune NO2

http://www.nissanclub.com/forums/northeastern-u-s/321997-4th-annual-northeastern-nissan-end-year-meet.html
SE-R Altima Driver is offline  
post #7 of 7 Old 03-06-2010, 09:03 PM
Registered User
 
ghostryder12's Avatar
 
Join Date: Mar 2010
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: 0 reviews
Question Battery light and E-brake light on

Quote:
Originally Posted by SE-R Altima Driver View Post
This is nissan's warning the Alternator is going bad. Had the same thing on 2 different nissan cars and both times it was the alternator.
FYI.
Sorry to bump this old thread.
While this is very good information, I just went to a 3rd Alternator in 13 months. 1st was the factory alternator for the '06 SE-R. In '09, the headlights and dash lights started to pulsate. Mechanic determined that the factory Alternator was bad. Replaced with aftermarket Alternator that lasted 13 months. Headlights and dash light began to pulsate again as with first Alternator. Mechanic replaced with another aftermarket alternator. Next day, the dash battery light and E-brake lights came on and volt meter dipped slightly, but headlight and dash light pulsating gone. Got to destination and when restarting, lights stayed off for 10 minutes. Lights came back on and dash volt meter dipped slightly. While traveling, Battery light and E-brake light went off and volt meter went back to normal. After 5 minutes, Battery light and E-brake light came back on. Mechanic researched all TSBs with no results. Mechanic found out that there is a "sensor" in the instrument cluster wiring behind the dash that may be the problem. Contacted Nissan dealer and they advised that there is no TSB, nor have they had any problems with that "sensor". However, Nissan advised that they have a "specially" made devise used to determine if that "sensor" is defective that is plugged into the vehicle.
Does this still sound like an Alternator problem?
Edit:
Drove to work last night and Battery light and E-brake light came on after 20 minutes of driving. Battery light and E-brake light went off after 3 minutes and came back on after 5 minutes. Each time the Battery light and E-brake light came on, the volt meter dipped slightly and went back to normal when the lights went off. Also, I noticed the dash lights dimmed slightly when the Battery light and E-brake light were on and normal when they were out. Driving home from work, Battery light and E-brake light did not come on entire trip.
Now I am totally confused.

Last edited by ghostryder12; 03-07-2010 at 01:18 PM.
ghostryder12 is offline  
Sponsored Links
Advertisement
 
Reply

  Nissan Forums : Nissan Forum > Nissanclub.com Nissan - Infiniti Enthusiast Forums > NISSAN ALTIMA FORUMS > 2002-2006 Nissan Altima Forums > 2002-2006 Nissan Altima Discussion (2.5 & 3.5) > 2005-2006 Nissan Altima SE-R Discussion

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Nissan Forums : Nissan Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome