Altima giving error code P2A00 - Nissan Forums : Nissan Forum
 
LinkBack Thread Tools Display Modes
#1 Old 07-17-2008, 06:04 AM
Registered User
 
Join Date: Sep 2007
Location: Indiana
Posts: 7
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: 0 reviews
(Thread Starter)
Unhappy Altima giving error code P2A00

Hey Guys having a problem on my 08 altima coupe. Service engine light came on today, Getting code P2A00 with an actron CP9175

P2A00
02 Bank1 Sensor1
RANGE/PERFOMANCE

I do not have an aftermark intake or exhaust - but my wife did drive the car through high water, a few weeks back. It shut off the engine, but after a good cleanup - including flushing / drain the transmission fluid (w/ the pricey nissan cvt transmission fluid) , new air fliter & oil. It has been driving fine. Then today service engine light came on..

The o2 sensor was something that may have taken moisture but I figure since it's been running ok for a few weeks it survived. Could a good clean with Electronic Cleaner - do the trick? Can this light be tripped by anything else (like gas cap?) if the light is coming on does it mean the sensor is shot - or just acting faulty? Why would car be driving fine?

Thanks for any help!

Pics of the damage - there was water (flood water from heavy storms) pooled in the airintake case - O2 sensor sits right above here I think.



Could leftover dirt from the water be interfering w/ sensor - am unsure if the shop that did the work cleaned the filter box good....



Water was only this deep - car sat in for about 15mins then was pushed thru and towed away



Wife looking sad


Luckily the engine wasn't hydrolocked or anything else - the interior carpet did get soaked, the water pooled about an inch in the backseat floors.
kulacool is offline  
Sponsored Links
Advertisement
 
#2 Old 07-17-2008, 06:16 AM
QR
Second to none
 
QR's Avatar
 
Join Date: Aug 2007
Location: Rio Dell, Ca
Posts: 1,451
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: 0 reviews

holy crap that sucks

QR is offline  
#3 Old 07-17-2008, 09:47 AM
Forty-something MPG
 
TheRupp's Avatar
 
Join Date: Sep 2006
Location: Scottsdale, AZ
Posts: 4,759
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: 0 reviews
I hope you don't have it pegged with a "FLOOD VEHICLE" title or electrical problems down the road...

I'm pretty sure that'll f*** up something and throw a code at that point.

. : The Rupp : .



.: 2007 3.5SE :: Precision Grey :: Sport Package :: CVT :: Höen Xenonmatch Plus Low Beams :. - Traded for:

.: 2008 3.5SE :: Dark Slate :: Premium Package :: CVT :: Garmin nüvi 350 Hardwire :: 20% Tint All Around :. - Gone

.: 2006 BMW 330i :: Sparkling Graphite :: Premium Package :: Sport Package :: 6MT :. - Sold

.: 2010 Scion tC :: Flint Mica :. - Sold

.: 2012 Chevrolet Cruze Eco :: 6MT :. - Awaiting more LED's

LED: LED Thread :: Footwells & Cupholder :.
TheRupp is offline  
#4 Old 07-17-2008, 02:52 PM
Hey man, where's my car?
 
velanzia's Avatar
 
Join Date: Aug 2007
Location: Brampton, ON, Canada
Posts: 987
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: 0 reviews
that sucks man. home come that much water went in? was it a huge pool?

(by the way nice road tho ..... but dangerous at night time with that pool)
velanzia is offline  
#5 Old 07-17-2008, 06:01 PM
Registered User
 
Join Date: Sep 2007
Location: Indiana
Posts: 7
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: 0 reviews
(Thread Starter)
Bump - anyone seens this code before....
kulacool is offline  
#6 Old 07-17-2008, 06:36 PM
SpeedLinesAreChasingMe!
 
kamikazeH20mln's Avatar
 
Join Date: Apr 2008
Location: Baltimore, MD
Posts: 1,307
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: 0 reviews
P2A00 - HO2S Circuit Closed Loop (CL) Performance Bank 1 Sensor 1 (PCM)

Hopefully it is not flood damaged. I would get a wet vac to get that water out of the air intake as the first step if you have not already and make sure everything is dried out in the air intake.

This is always why you don't drive through large pools of water :-P

08 Altima 4dr 3.5 SL CVT - Precision Gray w/ Charcoal Int. - Fully loaded
Mods: {WeatherTech mats}{28% tint}{Brazillan back w/ hamburger}{OEM Chrome Altima plate holder}{Bat's rear variance}{Stillen Rear Swaybar}{Injen Intake}{Black Depo tails}{Raceingline strut towerbar}{custom grounding kit}{Nissan Black painted OEM grill}{paint-matched fiberglass eyelids}{Raceingline Y-pipe]{Eibach Pro Springs}
kamikazeH20mln is offline  
Sponsored Links
Advertisement
 
Reply

  Nissan Forums : Nissan Forum > Nissanclub.com Nissan - Infiniti Enthusiast Forums > NISSAN ALTIMA FORUMS > 2007-2012 Nissan Altima Forums > 2007-2012 Nissan Altima Discussion (2.5 & 3.5)

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Nissan Forums : Nissan Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


<

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome