p0746 & p1778 quick fix? or new tranny? - Nissan Forums : Nissan Forum
 
LinkBack Thread Tools Display Modes
#1 Old 12-28-2011, 03:40 AM
Registered User
 
Join Date: Oct 2007
Posts: 23
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: 0 reviews
(Thread Starter)
p0746 & p1778 quick fix? or new tranny?

05 Murano 3.5 Sorry for posting on an Altima forum but, I know all the experts are here plus the Murano page looks dead. Transmission began whinning and car barely moves. I know its a Transmission pressure solenoid problem. My question is "can I just buy the solenoid" or do I have to pay $1200 for the entire valve body from the dealer?
EFM03 is offline  
Sponsored Links
Advertisement
 
#2 Old 12-28-2011, 10:19 PM
Snow... what
 
05SickSer's Avatar
 
Join Date: Mar 2011
Location: Everywhere
Posts: 3,009
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 1
Thanked 25 Times in 25 Posts
iTrader: 1 reviews
I think you need an entire valve body, or atleast thats what they tell you.

Take it apart and look at it. If it looks like you can simply take off the bracket for the soleniod and remove the soleniod, then you probably dont need a whole new valve body. But then again good luck trying to buy just the soleniod..

05SickSer is offline  
#3 Old 12-29-2011, 12:52 AM
Registered User
 
Join Date: Oct 2011
Location: Ontario, Canada
Posts: 143
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
iTrader: 1 reviews
You can buy another transmission and swap out the vavle body. If this doesn't fix it, put the valve body back in the replacement transmission and swap the transmissions.
imo000 is offline  
#4 Old 12-29-2011, 12:52 AM
Registered User
 
Join Date: Oct 2011
Location: Ontario, Canada
Posts: 143
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
iTrader: 1 reviews
What does the transmission fluid looks/smells like?
imo000 is offline  
#5 Old 12-29-2011, 03:11 AM
Registered User
 
Join Date: Oct 2007
Posts: 23
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: 0 reviews
(Thread Starter)
The fluid is just fine, nice color no burnt smell. It ran fine one day then the next when I turned it on it began whinning like a power steering gone bad noise, I turned the car off and back on and the noise went away. A couple of hrs later the noise came back and the tranny slips like crazy, because the lack of pressure I assume. We'll see what happens, I may take it to a friend who works at Nissan and get his discount to get it fixed.....seems like as soon as you pay something off, something else always comes up....thanks for the replies.
EFM03 is offline  
#6 Old 01-03-2012, 03:37 AM
Registered Abuser
 
2809's Avatar
 
Join Date: Sep 2009
Location: South Jersey
Posts: 209
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 1
Thanked 0 Times in 0 Posts
iTrader: 0 reviews
in my 2.5 when ever i make a left turn and accelterate out of the turn my car almost stalls out...the rpms drop car stops then the car feel a hard hit...then continues normal

"I was going to join the spec ops division of the boy scout reserves today, but they said that my tangelo belt in tae-bo and advanced levels of yo-yo warfare training make me over qualified. I guess it's time to talk to some of the other branches and see if they can help me. I hear the fireside girls have a pretty tough unit that has a focus on search and rescue of small mamals."

2005 Nissan Altima 2.5 S in Blue

* KYB GR2 Struts paired with H&R Springs * 5% Tints
* C-Mod Grille * Blacked out chrome trim * OEM Trunk Spoiler with Rear Window Spoiler * Montegi DP5 Wheels * Pioneer AVIC D3 Navi * Philips 4300k HID's * OEM Fogs * White LED Interior * LED license plate lights *SE-R tail lights *Ebay Headers * Ebay CAI w/ K&N Cone
2809 is offline  
Sponsored Links
Advertisement
 
Reply

  Nissan Forums : Nissan Forum > Nissanclub.com Nissan - Infiniti Enthusiast Forums > NISSAN ALTIMA FORUMS > 2002-2006 Nissan Altima Forums > Engine Performance (2002-2006)

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Nissan Forums : Nissan Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


<

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome