Need Help!! *Check Engine Light* - Nissan Forums : Nissan Forum
 
LinkBack Thread Tools Display Modes
  #1  
Old 04-21-2006, 06:42 AM
jus4fun jus4fun is offline
Registered User
 
Join Date: Apr 2006
Posts: 7
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: 0 reviews
Need Help!! *Check Engine Light*

hey guys,
i have a 89' 240sx fastback...i have the sohc motor in my car right now and the engine check light is on.....i talked to the mechanic and he said that the 02 sensor is brand new and so he said that it could be a bad connection to the 02 sensor....is that possible? need some help....the mechanic also mentioned that the casing around the throttle cable is loose which causes the car to run and a constant speed the wake up and take off at a faster speed...so basically, it lags then takes off....could that be a problem? need some help thank u....
Sponsored Links
Advertisement
 
  #2  
Old 04-21-2006, 10:14 PM
Jessica240sx's Avatar
Jessica240sx Jessica240sx is offline
Turd Ferguson
 
Join Date: Jun 2005
Location: Arizona
Posts: 292
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: 0 reviews
Why don't you just have the mechanic hook it up to the computer and hand you a print out of the exact codes the car is throwing? It would be much more useful and easier to see exactly what is wrong.

Sweet! That is tricked out my friend. Turbo!

  #3  
Old 04-22-2006, 11:34 AM
Mr.Powers Mr.Powers is offline
Registered User
 
Join Date: Oct 2005
Location: Peoria, Arizona
Posts: 11
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: 0 reviews
you can also try and retrieve the code yourself, Im not 100% sure about the 89 sohc but I know on my 91 Fastback DOHC the PCM is located passenger side under the glove box right hand side like where your passenger puts there right foot. remove that plastic cover and there it is. then you follow the instructions on this web site http://www.240sx.org/faq/articles/ecm_codes_doch.htm and that will tell you what is wrong. I found my EGR problem that way. Only bad is it is way to general kinda like that simpsons episode where mr. burns gets his car stolen and chief wiggam activates the cars tracking device " car gone car gone," " Yes we know the car is gone but where has it gone to?" "CAR GONE, CAR GONE!!!" lol anyway turned out it was just a hose that connected the EGR valve to another control valve. good thing I checked it out myself first I was about to buy a new EGR for 90 Bux, fixed the problem with some free rubber fuel line from autozone. good luck
  #4  
Old 04-24-2006, 04:21 AM
Jessica240sx's Avatar
Jessica240sx Jessica240sx is offline
Turd Ferguson
 
Join Date: Jun 2005
Location: Arizona
Posts: 292
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: 0 reviews
Grr.. is there a way to check the S14 codes without paying money hungry mechanics?

Sweet! That is tricked out my friend. Turbo!

  #5  
Old 04-25-2006, 10:37 PM
Ace's Avatar
Ace Ace is offline
Rockin the Kasbah
 
Join Date: Jan 2003
Location: Your Sister's Room
Posts: 4,106
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 10
Thanked 14 Times in 9 Posts
iTrader: 2 reviews
Goto Autozone and use the scan tool, or go down to you ECU, follow the directions on the ECU and cross refernce the blink codes with a haynes manual or FSM

97 240 - SR Power - 400whp

365th EN - OIF 3+4

Turbo Altima
  #6  
Old 04-26-2006, 06:09 AM
jus4fun jus4fun is offline
Registered User
 
Join Date: Apr 2006
Posts: 7
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: 0 reviews
thanks guys, i already did and i went to autozone and they said that they diagnose cars years 96 and above. I also brought it to another shop for another diagnosis and they said that the wiring harness wasn't repaired correctly when the sohc ka24 was swapped...the car was throwing a code 45which was fuel injectors....the mechanics said that if they took a look at the injectors, they would have to replace it...they were charging me $208.00 for one injector.....i just felt that the mechanic was bullshi*ing me because the fuel injectors wasn't leaking at the time of the diagnosis and the mechanic said it himself but i don't even now i still think it's not leaking...the mechanic also said that the car would be throwing random codes due to the fact that the wiring harness wasn't repaired correctly because of the swap...he said that the person who did the wiring didn't use the right guage wires and may cause short...could it be the wiring harness that is just messing everything up? unless that's what i think because the injectors seems fine....thanks for the help guys..
  #7  
Old 04-26-2006, 11:50 AM
Ace's Avatar
Ace Ace is offline
Rockin the Kasbah
 
Join Date: Jan 2003
Location: Your Sister's Room
Posts: 4,106
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 10
Thanked 14 Times in 9 Posts
iTrader: 2 reviews
Take it to another mechanic....

Not to be rude, but even the best of shops can have problems with specific car related things like a wire harness conversion! You're going to hafta take it to a specialty shop, or find someone/somewhere online there is a sohc-dohc conversion write up and trouble shoot from there

97 240 - SR Power - 400whp

365th EN - OIF 3+4

Turbo Altima
  #8  
Old 04-27-2006, 05:00 AM
jus4fun jus4fun is offline
Registered User
 
Join Date: Apr 2006
Posts: 7
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: 0 reviews
thanks guys, i'm taking it to the nissan dealership soon to get it repaired...i'm not really sure if its the injectors..i think it's the wiring harness........so i'ma get rediagnosed.
Sponsored Links
Advertisement
 
Reply

  Nissan Forums : Nissan Forum > Nissanclub.com Nissan - Infiniti Enthusiast Forums > NISSAN 240SX / SILVIA FORUMS > General Nissan 240SX / Silvia Discussion

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Nissan Forums : Nissan Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


<

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome