Replaced alternator and brake/battery lights still on - Nissan Forums : Nissan Forum
 
» Auto Insurance
» Featured Product
Wheel & Tire Center


NissanClub.com is the premier Nissan Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 02-17-2005, 06:51 PM
24D 24D is offline
Registered User
 
Join Date: Aug 2003
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: 0 reviews
Replaced alternator and brake/battery lights still on

Hello everyone after doing a search I found that when the battery light and brake light come on at the same time that the alternator is about to go. Well I replaced it with an OEM alt. and turned on the car and both lights still came on. What else could be causing this? Any help would be appreciated.

FYI
It's a 1996 Altima
I don't have a system
The brake fluid level is fine.

Thanks
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 02-17-2005, 06:56 PM
Breu Meister
 
Join Date: Feb 2003
Location: Long Island, new york
Posts: 6,646
Thanks: 0
Thanked 1 Time in 1 Post
iTrader: 1 reviews
possibly a relay; also check fuses and connections to your battery.
__________________
R.I.P. 2000 altima SE
Hello...
2003 Majestic Blue 6 speed maxima
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 02-18-2005, 09:25 PM
24D 24D is offline
Registered User
 
Join Date: Aug 2003
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: 0 reviews
Has this happened to anyone else after replacing the alternator. The brake and battery light staying on, I mean.
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 02-18-2005, 09:28 PM
TPhelps155's Avatar
Member
 
Join Date: Mar 2002
Location: BOSTON, MA
Posts: 8,112
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: 0 reviews
Yes, meaning the alternator is still bad (the new one you got).

Was the new one rebuilt? If so my guess its that. Happened to me. I dont know what else it could be.
Reply With Quote Quick reply to this message
  #5 (permalink)  
Old 02-18-2005, 09:33 PM
coach's Avatar
Registered
 
Join Date: Nov 2000
Location: Toronto
Posts: 9,499
Thanks: 8
Thanked 2 Times in 2 Posts
iTrader: 0 reviews
would resetting the ECU help?
__________________


Reply With Quote Quick reply to this message
  #6 (permalink)  
Old 02-18-2005, 09:42 PM
The Don.
 
Join Date: Jul 2002
Location: Northern VA
Posts: 6,109
Thanks: 2
Thanked 39 Times in 26 Posts
iTrader: 1 reviews
Quote:
Originally Posted by coach
would resetting the ECU help?
No, because the ECU does not play any part in the circuit.

If the battery/brake light is still ON then the "new" alternator must be bad or has gone bad.
__________________


'94 Nissan Altima SE, 5spd. Ultra Red (AJ4).
Erebuni 905, Turboing, Hotshot CAI, UR Pulley, Calum ECU,
HUD & ATC retrofitted, DEPO lamps /w Silverstars, NGK Ignition wires.
ITEMS FOR SALE

Last edited by jserrano; 02-28-2005 at 05:19 PM. Reason: Typos
Reply With Quote Quick reply to this message
  #7 (permalink)  
Old 02-18-2005, 10:04 PM
Registered User
 
Join Date: Aug 2001
Posts: 3,514
Thanks: 0
Thanked 5 Times in 5 Posts
iTrader: 0 reviews
There's probably an extremely good chance it's bad if it came from:
1. Autozone
2. Advance
Any other chain store that sells similar quality electric crap...

I've always heard NAPA, CarQuest, O'Reilly's(suprising) have decent alts/starters, etc, depending on the area...

And if the store offers a Lifetime warranty, usually there's a good chance you'll be replacing it for a lifetime...

Jeremy
Reply With Quote Quick reply to this message
  #8 (permalink)  
Old 02-18-2005, 10:15 PM
Registered User
 
Join Date: Jan 2005
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: 0 reviews
Have you tried a volt meter on battery? Check volts before starting then after its started you should see an increase in volts to around 14.5 if alternator is good.
Reply With Quote Quick reply to this message
  #9 (permalink)  
Old 02-19-2005, 12:12 AM
SHAWN's Avatar
Import Tech.
 
Join Date: Sep 2000
Location: Portland OR.
Posts: 4,667
Thanks: 0
Thanked 2 Times in 2 Posts
iTrader: 0 reviews
Batt and brake light on when the car is running is Alternator ... or you have a short to ground on the wire ...
__________________
SHAWN
Ger-Brock & Co. Portland OR.
'99 G20t Driver
'09 Sentra FE+ Wifes
'98 Sentra SE Time Attack
'06 Pathfinder SE Family Cruiser
'93 Altima SE 5 spd. 13.97 @ 97 MPH ..All Motor ..
( Sold )
'93 G20 12.0 @ 119 MPH Built SR20DET
( Sold )
My Nissan Site !!
Reply With Quote Quick reply to this message
  #10 (permalink)  
Old 02-19-2005, 08:47 PM
24D 24D is offline
Registered User
 
Join Date: Aug 2003
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: 0 reviews
I got the alternator from a Nissan dealership. And I tried resetting the ecu. On the short to ground on the wire do you mean the wire coming from the alternator, I'm guessing the wire that screws into the back using a small phillips head screw is the ground wire. It would definately suck if the new alternator is bad especially since it came from the dealership.

Thanks for the replies. I should have known it wasn't going to work since I didn't have a very hard time replacing it. If you guys have any more ideas please post.
Reply With Quote Quick reply to this message
  #11 (permalink)  
Old 02-19-2005, 10:23 PM
coach's Avatar
Registered
 
Join Date: Nov 2000
Location: Toronto
Posts: 9,499
Thanks: 8
Thanked 2 Times in 2 Posts
iTrader: 0 reviews
you should have some type of warranty from the dealership on new parts if they are DOA. just take it back and get a new one
Reply With Quote Quick reply to this message
  #12 (permalink)  
Old 02-28-2005, 02:26 AM
24D 24D is offline
Registered User
 
Join Date: Aug 2003
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: 0 reviews
Can anyone enlighten me on what ground wire I should be looking for? Or should I add an additional ground? Thanks
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  Nissan Forums : Nissan Forum > Nissanclub.com Nissan - Infiniti Enthusiast Forums > NISSAN ALTIMA FORUMS > 1993-2001 Nissan Altima Forums > General Nissan Altima Discussion (1993-2001)


Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Nissan Forums : Nissan Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT. The time now is 07:05 PM.


Powered by vBulletin®. Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.3.2
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.