weird gas smell - Nissan Forums : Nissan Forum
 
LinkBack Thread Tools Display Modes
#1 Old 03-13-2002, 10:21 AM
Registered User
 
Join Date: Mar 2002
Posts: 48
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: 0 reviews
(Thread Starter)
weird gas smell

when im just riding around or just start up my car there is usually a smell of gas or someother weird smell thats in my car is that a problem?? an if it is whats it coming from
Altima Zero1994 is offline  
Sponsored Links
Advertisement
 
#2 Old 03-13-2002, 10:42 AM
Registered User
 
Peterson's Avatar
 
Join Date: Sep 2000
Location: VA
Posts: 22,052
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
iTrader: 0 reviews
If it sorta smells like rotten eggs than it's your catalytic convertor going.
Peterson is offline  
#3 Old 03-13-2002, 01:19 PM
sittin on chrome....
 
bzkit's Avatar
 
Join Date: Aug 2001
Location: lex, KY
Posts: 503
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: 0 reviews
Quote:
Originally posted by Peterson
If it sorta smells like rotten eggs than it's your catalytic convertor going.
I don't have a catalytic converter, but mine doesn't smell all that bad.

The car...
94' Ultra Red SE
bzkit is offline  
#4 Old 03-13-2002, 06:24 PM
Registered User
 
Peterson's Avatar
 
Join Date: Sep 2000
Location: VA
Posts: 22,052
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
iTrader: 0 reviews
If you don't have a cat then yours wouldn't smell at all.....

The rotten smell is the catalyst agents in the convertor going bad.
Peterson is offline  
#5 Old 03-13-2002, 06:35 PM
from way way back
 
Join Date: Oct 2000
Posts: 1,672
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: 0 reviews
if you dont have a cat than your not passing inspection either...
CJB_316 is offline  
#6 Old 03-13-2002, 06:38 PM
Resident drunken chef!
 
scootter's Avatar
 
Join Date: Jan 2001
Location: pa,usa
Posts: 2,524
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 1
Thanked 0 Times in 0 Posts
iTrader: 0 reviews
Did you check under the hood for any gas leaks? My cousin had the same smell(on a protege), so I opened up the hood, and one of his injectors was leaking realy bad
scootter is offline  
#7 Old 03-13-2002, 07:41 PM
Registered User
 
Join Date: Aug 2001
Location: ohio
Posts: 37
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: 0 reviews
i had the same problem but it was teh Evaporatoin control cannister which is located next to the fuel filter. What it does is takes all the exhause emissions and regenerates them back to the motor to be burned and if part goes out it make your car smell like gas. until its fixed thats what is wrong with your care not your cat. converter.

94 altima se
66 black mustang
pierre45eb is offline  
#8 Old 03-16-2002, 10:31 PM
sittin on chrome....
 
bzkit's Avatar
 
Join Date: Aug 2001
Location: lex, KY
Posts: 503
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: 0 reviews
Quote:
Originally posted by CJB_316
if you dont have a cat than your not passing inspection either...
They don't have inspections here in kentucky.. I need a new cat though, anyone know where I can get a really cheap one?

The car...
94' Ultra Red SE
bzkit is offline  
#9 Old 03-16-2002, 10:34 PM
Registered User
 
Peterson's Avatar
 
Join Date: Sep 2000
Location: VA
Posts: 22,052
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
iTrader: 0 reviews
Peterson is offline  
#10 Old 03-16-2002, 11:10 PM
Jr. Lord Of Search
 
Join Date: Aug 2001
Location: Rochester NY
Posts: 2,594
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
iTrader: 0 reviews
Quote:
Originally posted by bzkit


They don't have inspections here in kentucky.. I need a new cat though, anyone know where I can get a really cheap one?
catco hi-flow cat from summitracing.com


Mods: Fan Delete///Borla Exhaust
MikeV is offline  
#11 Old 03-16-2002, 11:26 PM
Damn! I Drive a Civic
 
Join Date: Sep 2001
Location: Dallas, Texas
Posts: 4,703
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: 0 reviews
are you sure you putting gas in the right place? theres this little lever inside the car push it down and opens a gas cap on the rear drivers side put the gas in there.... it helped me with the smell alot!! j/k

06 Altima 2.5S - 5 Speed
m3dia_lab is offline  
#12 Old 03-17-2002, 01:51 AM
sittin on chrome....
 
bzkit's Avatar
 
Join Date: Aug 2001
Location: lex, KY
Posts: 503
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: 0 reviews
Quote:
Originally posted by Peterson
www.summitracing.com
thanks

The car...
94' Ultra Red SE
bzkit is offline  
#13 Old 03-22-2002, 06:31 AM
Sexy Biatch
 
Join Date: Mar 2002
Location: Austin TX
Posts: 189
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: 0 reviews
Quote:
Originally posted by pierre45eb
i had the same problem but it was teh Evaporatoin control cannister which is located next to the fuel filter. What it does is takes all the exhause emissions and regenerates them back to the motor to be burned and if part goes out it make your car smell like gas. until its fixed thats what is wrong with your care not your cat. converter.

Are you describing the Exhaust Gas Recirculation (EGR) valve?

Mechanic was telling me that was the cause of the smell for me. Although the smell coming from my car is occasional. Although since yesterday I have noticed a gas smell in the car when I enter after having it parked for a bit.
mc-fine is offline  
#14 Old 03-23-2002, 12:01 AM
Registered User
 
Join Date: Feb 2001
Location: Milford, CT
Posts: 2,049
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 2
Thanked 1 Time in 1 Post
iTrader: 0 reviews
Quote:
Originally posted by pierre45eb
i had the same problem but it was teh Evaporatoin control cannister which is located next to the fuel filter. What it does is takes all the exhause emissions and regenerates them back to the motor to be burned and if part goes out it make your car smell like gas. until its fixed thats what is wrong with your care not your cat. converter.
It does sound like a EVAP problem, but the EVAP system has nothing to do with the exhaust. It recycles gasoline evaporation from the gas tank back into the engine intake.
kenshi is offline  
Sponsored Links
Advertisement
 
Reply

  Nissan Forums : Nissan Forum > Nissanclub.com Nissan - Infiniti Enthusiast Forums > NISSAN ALTIMA FORUMS > 1993-2001 Nissan Altima Forums > General Nissan Altima Discussion (1993-2001)

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Nissan Forums : Nissan Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


<

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome