Hi - Nissan Forums : Nissan Forum
 
LinkBack Thread Tools Display Modes
post #1 of 1 Old 04-07-2016, 02:55 AM Thread Starter
Registered User
 
Join Date: Apr 2016
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: 0 reviews
(Thread Starter)
Hi

Iam not sure if this is the right place first time I have an 06 Nissan Titan which the fuse box by the battery post was corroded I didn't start one morning so I went to and cleaned it and tried to start and no power to the dash or ignition but yet I had power so I looked at the fuse box they were all good but it landed in side fuse box had separated a little bit... so I crossed it over with a copper wire and it started and it worked but now it has no power in Drive like it's not shifting down 2 1st once I get up to 30.. 50 has the same amount of power but starting off very sluggish and reverse has lots of power any ideas what this could be powertrain module.... limp mode ... Or mabye rest codes..any help would sure be appreciated

wildtrophys is offline  
Sponsored Links
Advertisement
 
Reply

  Nissan Forums : Nissan Forum > Nissanclub.com Technical and Specific Interest Nissan Discussion > ECM / ECU Tuning

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Nissan Forums : Nissan Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome