The Nissan Club banner
1 - 4 of 4 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
So I just fought my '04 Maxima today. Tie rod ends, CV Axle (passenger), serpentine belts, rear brakes, and of course an oil change.

Was really hoping my front end noise, clunks at neighborhood speeds when hitting bumps and potholes indistinguishable from driver or passenger side (seems like both), was caused by my incredibly sloppy putter tie rod ends.

Ahhh if only I could be so lucky. I have been browsing your wonderful forum and believe I know have a step in the right direction. I am having trouble navigating thru the forum. Can find things thru Google search but not via the forum itself.

I found the 6th gen forum but all I can do is scroll thru a lot of posts. Expected subsections when I opened it. More than likely I am using the search function wrong. Some tinkering and I'm sure I'll get it.

http://www.nissanclub.com/forums/2002-2006-nissan-altima-discussion-2-5-3-5/251408-clunking-noise-front-end-2003-3-5-a-9.html

This seems to have all my answers but I don't quite know how to get to it. I just bookmarked it from a link within another forum topic I found via Google.

Anyways you guys seem real professional and I'm excited to have a valuable resource at my disposal to save me time, money, and headaches. Thanks guys.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #4 ·
Thank you very much, I will do this repair when it cools down some today. Thanks for the link. Should have known when I had to pull my coolant reservoir and fuse block to reach the adjustment screw on my idler pulley, to change my serpentine belt, that my problem would be something silly like this
 
1 - 4 of 4 Posts
Top