The Nissan Club banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Bought my daughter a 08 coupe a few weeks ago. I noticed the other day that the third brake light isn't working. I removed the light and made sure its getting power and it is. I checked the dealer for a replacement and he said I have to buy the whole assembly for 127.00. Is there anywhere that I can just buy the LED light. Thanks
 

·
Registered
Joined
·
129 Posts
I had an issue last week with mine.. Got mine to work again after it was very dim, maybe I can help if you are good with a soldering iron. What I did was the same, checked for voltage at the plug, then took the circuit board apart by prying the plastic covers off like the bezel. I set my multimeter to test diodes (gives a small voltage to test) and each one was working but just dim. All I did was touch each solder joint with some heat and added a tiny bit of solder to beef up the connection.
I put it back on the harness and it works like new. So if you can do that or know someone who can take 10 mins to fix it I bet it would help. If not just look very close to the connections as vibration from the car can loosen the small electronics over time.
 
  • Like
Reactions: This this spot

·
Registered
Joined
·
1 Posts
I had an issue last week with mine.. Got mine to work again after it was very dim, maybe I can help if you are good with a soldering iron. What I did was the same, checked for voltage at the plug, then took the circuit board apart by prying the plastic covers off like the bezel. I set my multimeter to test diodes (gives a small voltage to test) and each one was working but just dim. All I did was touch each solder joint with some heat and added a tiny bit of solder to beef up the connection.
I put it back on the harness and it works like new. So if you can do that or know someone who can take 10 mins to fix it I bet it would help. If not just look very close to the connections as vibration from the car can loosen the small electronics over time.
This worked so good!! I connected the two main wires together with solder. That is what worked for me. I had to use a good amount to get it to work.
 
1 - 3 of 3 Posts
Top