The Nissan Club banner
1 - 7 of 7 Posts

·
your mom felt my length
Joined
·
841 Posts
Discussion Starter · #1 ·
Well i'll start in the beginning. Last week i went to class at night and after 3 hours i hopped in my car to head home, i turned it on and it stuttered a little but then it went fine. I thought it was just cause it was a cold night so i didn't think anything of it.

Sautrday, i went to go see my girlfriend (she lives 2 hours from me) and about 10 miles from her house the car died, so i called her and asked her to pick me up so we can find a shop, but before she got to where i was the car started up fine. But it was 4:30 already and no shops around or anything that could do anything. So i just left it at her house then sunday i was supposed to come home for work i nthe morning. So car started up fine and i headed home. 77 miles away from her house, and 80 more miles to get to my house the car shut off going 70...so i just let it roll to a stop (my girlfriend, the wise one, insisted that she follow me just to make sure) so me and my girl just waited on the side of the road for alittle bit and decided to see if my car would start up. Nothing.

So we called a tow truck, and took it to some local gas station/mechanic place and had them look into it. At first i thought hey, it's jut the fuel pump not getting gas to the engine, and everyone there thought the same thing too, so they did tests, not the pump, not the plubs, not the oil, not anything, after 4 hours my timing chain was broken and teh car couldn't do anything. They said it was $1000 for the labor cause they had to take out the engine and thsi and that. So i said forget it.

So i took my girlfriend home, borrowing her car for the week, and today, my dad, me and some friends rented a truck and stuff and towed it to one of our mechanic friends to check it out...so that's where i am at this point, waiting to see how much this is gonna hurt $$$ wise...

95 Altima, 167k, first problem (besides battery replacement)
 

·
Shift_for yourself
Joined
·
182 Posts
What the in the world, how did your timing chain end up broken??? That should be there fault????

Anyway as far as your car stuttering and sometimes starting, u may need a new distributor, I had kinda the same problem and it ended up being my camshaft angle sensor, which they say can't be replaced without changing the distributor (where its located).

If that is the case its about $150 or so and u can change it yourself.
 

·
your mom felt my length
Joined
·
841 Posts
Discussion Starter · #3 ·
sorry, they didn't break my timing chain, they said that's the problem, that my timing chain is busted. Also, i've never seen smoke come out of my air filter (K&N drop in), that kinda shocked me see taht while they tried to test my car...hmmm...

i hope it's something easy to fix...
 

·
I Don't Drive An Altima
Joined
·
417 Posts
Timing Chain = New engine. About the same price........ Hard to believe the tiing chain broke..... did yo usee the inside of the engine with the valve cover off?
 
Joined
·
141 Posts
similar problem

I had this happen... i was driven car totalyl stalled.. thought it could eb anything... found out it was a timing chain issue... but...it really was only the flywheel....i got an estimate to replace the timing chain, tensioner..and something else would ahve run 750.... so 1000 is a bit too much.... a cause for a broke timing chain... "NEUTRAL DROPS!" done any of those, buddy??
 

·
your mom felt my length
Joined
·
841 Posts
Discussion Starter · #6 ·
nope, no netrual drops, i baby my car...i knew something was gonna give sooner or later though withh my mileage, just i wasn't expecting it to cost this much...

anyways, having another mchanic (2 personal friends actully) look at it...instead of some shop in the middle of no where.
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top