The Nissan Club banner
1 - 9 of 9 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
Looking for help with deciphering what the battery light and e-brake light mean coming on together, and going back out after a few seconds?

Any help appreciated
 

·
Registered
Joined
·
180 Posts
Nissan's warning that your alternator is not operating correctly. Have it checked out. More than likely you will need to replace alternator...
 

·
09 Altima 3.5SE 6MT Sedan
Joined
·
6,365 Posts
See this thread http://www.nissanclub.com/forums/ni...on/462690-nissan-idiot-lights-why-bother.html

Check my 'Alternator' thread in my .sig below too.

Are you sure about the indicator lights names? Seems redundant to have 'Brake' and 'e-brake' lights. As @nismopc deduced above, it's most likely your OEM Hitachi alternator's regulator giving up the ghost...you will get stranded as the ECU will prevent the engine doing anything but idle...you can use some of the tricks in my thread below to get home...but the condition is progressive and you will need to start disconnecting the batter cable when you park so you can restart the car again.

The good news is the 2.5 alternator replacement is much simpler than the 3.5. Also, please replace your battery negative cable which terminates on your transmission--there is a strong correlation between a bad engine ground and dying alternators. This is $30 part and well worth it.
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #5 ·
See this thread http://www.nissanclub.com/forums/ni...on/462690-nissan-idiot-lights-why-bother.html

Check my 'Alternator' thread in my .sig below too.

Are you sure about the indicator lights names? Seems redundant to have 'Brake' and 'e-brake' lights. As @nismopc deduced above, it's most likely your OEM Hitachi alternator's regulator giving up the ghost...you will get stranded as the ECU will prevent the engine doing anything but idle...you can use some of the tricks in my thread below to get home...but the condition is progressive and you will need to start disconnecting the batter cable when you park so you can restart the car again.

The good news is the 2.5 alternator replacement is much simpler than the 3.5. Also, please replace your battery negative cable which terminates on your transmission--there is a strong correlation between a bad engine ground and dying alternators. This is $30 part and well worth it.

Appreciate your input! It is the same light that turns on when the E-brake is engaged at the same time as the battery light showing up. They last a few seconds then go out, and at random times. Would this also cause my 4 way lights to turn on and off rapidly occasionally as well? (It flickers on and off 2 or 3 times usually then stops)
 

·
09 Altima 3.5SE 6MT Sedan
Joined
·
6,365 Posts
Those symptoms are not 100% consistent with the 'alternator experience'. Start by replacing the negative cable assembly, this is cheap and easy to do yourself. You could just have a really bad ground...that would explain the inconsistent nature...alternator issues tend to be repeatable and escalate.
 

·
Registered
Joined
·
6 Posts
I have a problem with my 2013 Nissan Altima 3.5SV. My windshield sprayer wasn't working so I started to check the fuses. I pulled few of them out to check if they were bad. After that I started my car and I noticed that battery and brake light came on at the same time. I went to see my friend which he owns a repair shop, he checked everything on the computer and said that everything is OK. He took the negative out from battery to see if alternator was working and he said its fine. I checked the battery and it showed 15.3. Does anyone knows what the issue is?
 

·
09 Altima 3.5SE 6MT Sedan
Joined
·
6,365 Posts
I have a problem with my 2013 Nissan Altima 3.5SV. My windshield sprayer wasn't working so I started to check the fuses. I pulled few of them out to check if they were bad. After that I started my car and I noticed that battery and brake light came on at the same time. I went to see my friend which he owns a repair shop, he checked everything on the computer and said that everything is OK. He took the negative out from battery to see if alternator was working and he said its fine. I checked the battery and it showed 15.3. Does anyone knows what the issue is?
Most likely alternator. See link in my .sig for my own experience.
 
1 - 9 of 9 Posts
Top