The Nissan Club banner

1 - 16 of 16 Posts

·
Registered
Joined
·
929 Posts
Discussion Starter #1
Hello,

My question number 1 is, does this 22680-CA000 look like your MAF on your 2005 Altimas?

In a previous thread I had addressed the fact I was going to purchase a 22680-CA000 (2005 altima) MAF after having my 22680-8J000 MAF (2002 altima) blow

After picking up the MAF I noticed a harness connection difference.

Both 5 pin



This is my MAF wiring harness.



I have enough spare MAF parts to make my own custom harness and still have a stock version just incase it doesnt work.

If the 2005'ers all say its the same connection/MAF style on theirs I will try it.

Thanks in advance,

PROENDO.
 

·
Registered
Joined
·
929 Posts
Discussion Starter #2
2005'ers come on pop the hood and let me know if it looks the same.

Here is an image from far away on Nissan2k5AltiSE the MAF looks alot like the one in my image but I cant tell if the pin config is the same.

 

·
Registered
Joined
·
929 Posts
Discussion Starter #5
Can you confirm one more thing about the color of the wires.

In picture #3 left to right what are the exact colors of the harness.

ie red (with green stripe) or Yellow (with green stripe)

for each pin 1-5

Thanks.
 

·
Registered
Joined
·
929 Posts
Discussion Starter #7 (Edited)
Well that is interesting,

mine from left to right is

1) yellow (with green stripe)
2) red (with green stripe)
3) black
4) red
5) white

I wonder if the wires still do the same thing and are in a different order.

I tried calling a dealer and asking for the output of each wire on both cars but that was a no go.

Anyone have the information on a CD service manual somewhere? Sounds like I need to know a Nissan Mechanic to get the information for both 02 and 05 models.

I may just try hooking it up in the order listed by Nissan2k5AltiSE and see what happens.
 

·
...
Joined
·
1,873 Posts
Just a guess, but if both MAFs have the same colored wires and you are probably going to use another connector, just rearrange the wires appropriately. I wonder how much difference other than the connector and order of wires there is between the crappy 02 MAFs and the 'improved' 05 MAFs. Stronger screen, more sensitive....
 

·
Registered
Joined
·
929 Posts
Discussion Starter #14 (Edited)
1130 error code

Well I finally installed the new MAF sensor.

I hooked it up just as Altima-02 had guessed

if both MAFs have the same colored wires and you are probably going to use another connector, just rearrange the wires appropriately
After the setup was tripple checked for accuracy I took out my old one and installed my new MAF sensor and cliped it in.

The moment of truth.

The engine turned on and was able to rev past 2000 rpm with out a hich, took it around the block and seemed reletivly smooth.

When I stopped however the idle begain to spudder a bit and I had to rev it to keep from stalling. I then proceeded to check everything again.

Everything seemd ok so I started it up again , this time the ECU generated an error code. I did the ECM diagnostic procedure and got

1 blink 1blink 3 blinks 10 blinks

1130?

Any idea what that is? I reset the ecu same result the next time I started it . Also tried the air volume reset.
No difference.


It just plain idles a bit funny but has not stalled.

Any one know what 1130 is?
 
1 - 16 of 16 Posts
Top