The Nissan Club banner
1 - 7 of 7 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
First time posting. everywhere i have searched comes up as a steering lock problem. but is 2010 it looks like they did away with the whole contraption. the red key indicator light comes on in the tachometer section of the dash and a clicking comes from the lower left side of the dash. i have been able to get it to start by putting it in neutral and holding the switch down, but it won't start in park.

1. new car battery-no change
2. new key fob batter - no change
3. place fob in slot - no change
4. turn steering wheel while on/off - no change

anyone have idea of what to check next? forum searches keep turning up the steering lock from symptoms. anything else this could be?
 

·
09 Altima 3.5SE 6MT Sedan
Joined
·
6,365 Posts
You are correct...no steering column interlock from '10 and later.

I suspect it could be your brake pedal switch as it is a common fault.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #3 · (Edited)
is it a multi stage switch? because all the brake lights are coming on/off. i also can use the cruise control once i got it started.

just went outside and the light stays on all the time now while in park. if i shift to neutral and try to start it right away it will start but if i leave it in neutral the light comes back on and it won't start. is there a way to disable the security features?
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #4 ·
bought a new switch and swapped it out. no change. the old one still works too with all the pins doing the same as the new one on a multimeter.
 

·
09 Altima 3.5SE 6MT Sedan
Joined
·
6,365 Posts
There is also a switch on the autobox gear selector. Could be that or the associated harness preventing the start, after i re-read your first post...that was a pretty big clue about the starting in neutral. Definitely worth taking the cowl off the gear selector and beeping out that switch (since we now know you have a multimeter...and are handy :) ) Do you know where to get the relevant wiring diagram--if not click HERE and look at page STR-12
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #6 ·
Figured I would wrap this up. It turned out to be the something wrong with the brake light switch. There is a service bulletin out to take care of it at our cost. its NTB10-139. The fix involves wiring in a new sub harness and relay pack into the brake light switch wiring. Dealership told me to call Nissan north american to try and get the parts reimbursed, with no luck. Pretty disappointed.
 

·
09 Altima 3.5SE 6MT Sedan
Joined
·
6,365 Posts
Figured I would wrap this up. It turned out to be the something wrong with the brake light switch. There is a service bulletin out to take care of it at our cost. its NTB10-139. The fix involves wiring in a new sub harness and relay pack into the brake light switch wiring. Dealership told me to call Nissan north american to try and get the parts reimbursed, with no luck. Pretty disappointed.
Here is a link to the NTB
 
1 - 7 of 7 Posts
Top