The Nissan Club banner

1 - 8 of 8 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter #1
Ok i have a 2011 altima 2.5s coupe automatic. I kept getting codes for the stepper motor and shift solenoid b. I ordered a stepper motor. Changed it. Now when its driving the transmission will not go into 2nd 3rd and so on. Even when i use the manual shift mode that doesn't change the ratio either. Now I have every single code on for the transmission possible. Anyone know if its a wiring problem or something? If more info is required i can provide it. Thank you to anyone who can help me.
 

·
09 Altima 3.5SE 6MT Sedan
Joined
·
5,675 Posts
Just because you got a code for the stepper motor doesn't mean that it, itself was actually the problem. Keep in mind:

TCU (transmission computer) --> Drive electronics --> wiring harness/connectors --> stepper motor --> (bunch of other hydraulic/mechanical systems that take the stepper motor output and actually change pulley ratios)

So just because the TCU throws a code for a stepper motor, doesn't mean it's smart enough to debug the control chain all the way to the shift function. All it's saying is 'hey, I told the stepper to do X, but it didn't according to sensor Y (somewhere in the chain)'.
 

·
09 Altima 3.5SE 6MT Sedan
Joined
·
5,675 Posts
Sorry...I don't know how I missed the entire second half of your post (like all codes present). Sounds like you need to replace the valve body (or solenoid B at a min) as well and go have it reprogrammed by Nissan.
 

·
Registered
Joined
·
12 Posts
Discussion Starter #4
So my plan was to buy a new valve body and put it in but even then I have to have it reprogrammed by Nissan?
 

·
09 Altima 3.5SE 6MT Sedan
Joined
·
5,675 Posts
FSM Page TM-255, Service Schedule B clearly indicates (dealer) reprogramming required if anything in transaxle changed even if TCU stays the same.
 

·
Registered
Joined
·
61 Posts
I also just replaced my stepper motor and entire Valve body. Now it's even worse. I haven't taken it to the dealership yet because I'm assuming they're just going to tell me I need a new transmission.
 

·
Registered
Joined
·
12 Posts
Discussion Starter #7
Well Ive narrowed the problem down (hopefully) and the only issue I'm having now is that the car moves and runs fine but the rpms dont change after the selector says "2" it just keeps revving up.
 
1 - 8 of 8 Posts
Top