The Nissan Club banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hello there, I own a 2012 Nissan Altima 2.5L Coupe. The past few months I have noticed a whine coming from the engine whenever I accelerate at a high rate of speed, around 70-80 mph. I haven’t thought much of it but today I was driving on the freeway, going about 85, I went to pass another vehicle and noticed that I didn’t hear the whine anymore, and I noticed that car wasn’t as jumpy as it normally is when I press on the gas pedal. I looked down at the spedometer and put my foot to the floor only to realize that my car was hardly accelerating. It took a very long time to accelerate. I took the car out to see if the car was still not accelerating like it was earlier, and all the problems went away. After a but if driving the whine did began to come back but I didn’t drive another 5 minutes from when I first heard the whine on my second drive. I would like to note as well, my engine temperature gauge is sitting a little under the middle. This is super confusing to me, and I was wondering if anyone on these forums could help me out. I don’t know too much about cars. I just need some help trying to find out what happened. If any of you guys have had similar mis haps with your own cars. Please any information that might help would be much appreciated! Also sorry, if I’m posting to the forums in the wrong manner. I’m new to these sorts of thing and just found the first way I could get my word out here. Again any help would be awesome! I don’t really like going to a shop, or even less so to Nissan themselves. They charge through the roof, and money is a little tight these days! Cars ran for 86479.1 miles.
 

·
Registered
Joined
·
1,602 Posts
Hello there, I own a 2012 Nissan Altima 2.5L Coupe. The past few months I have noticed a whine coming from the engine whenever I accelerate at a high rate of speed, around 70-80 mph. I haven’t thought much of it but today I was driving on the freeway, going about 85, I went to pass another vehicle and noticed that I didn’t hear the whine anymore, and I noticed that car wasn’t as jumpy as it normally is when I press on the gas pedal. I looked down at the spedometer and put my foot to the floor only to realize that my car was hardly accelerating. It took a very long time to accelerate. I took the car out to see if the car was still not accelerating like it was earlier, and all the problems went away. After a but if driving the whine did began to come back but I didn’t drive another 5 minutes from when I first heard the whine on my second drive. I would like to note as well, my engine temperature gauge is sitting a little under the middle. This is super confusing to me, and I was wondering if anyone on these forums could help me out. I don’t know too much about cars. I just need some help trying to find out what happened. If any of you guys have had similar mis haps with your own cars. Please any information that might help would be much appreciated! Also sorry, if I’m posting to the forums in the wrong manner. I’m new to these sorts of thing and just found the first way I could get my word out here. Again any help would be awesome! I don’t really like going to a shop, or even less so to Nissan themselves. They charge through the roof, and money is a little tight these days! Cars ran for 86479.1 miles.
"I don't know too much about cars" is the most important thing you wrote here. What this tells me is that you personally are not going to replace parts until your car is all better...you will pay others to do it.

I would suggest you take your car to a Nissan dealer and pay the diagnostic fee to find out what is causing your problem.

My first thought is your CVT is going bad, but I would not expect you to replace the CVT without proper diagnostic testing.

The whine you hear could be the CVT, could be the alternator, could be the A/C compressor, could be the idler pulley, could be wheel bearings, could be CV joints, could be tire noise.

It gets expensive replacing the "could be's"...get a proper diagnosis and go from there.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
"I don't know too much about cars" is the most important thing you wrote here. What this tells me is that you personally are not going to replace parts until your car is all better...you will pay others to do it.

I would suggest you take your car to a Nissan dealer and pay the diagnostic fee to find out what is causing your problem.

My first thought is your CVT is going bad, but I would not expect you to replace the CVT without proper diagnostic testing.

The whine you hear could be the CVT, could be the alternator, could be the A/C compressor, could be the idler pulley, could be wheel bearings, could be CV joints, could be tire noise.

It gets expensive replacing the "could be's"...get a proper diagnosis and go from there.
I will gladly replace anything that I can myself. I have access to the tools and knowledge to do so, i just meant i don’t know too much about what symptoms go to what problems. Thank you for your help!
 
1 - 3 of 3 Posts
Top