The Nissan Club banner
1 - 7 of 7 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Good morning everyone,

let me start with this,,,, i never own a nissan altima before, i just purchased a 2012 2.5s and im very happy with it, rides smooth gas saver and lots of space.

Unfortunately when i bought did not know that the information control panel under the speedometer it suppossed to be on...After more research and videos i found that should be working and displays a lot of information.

for some reason the screens its black and wont display any info.

Anyone that can help how to solve this issue?

Thank you in advance.
 

·
2010 2.5 SL
Joined
·
588 Posts
Just to help us troubleshoot;

What have you tried? What buttons have you pressed?

I believe that the control panel works by a backlit LCD. If that is the case, then it may simply be a broken light source. (I base that opinion solely on its appearance and not any sort of research).
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #3 ·
Hello MRR,

I checked the fuses under the stearing wheel and all of them look good.

I noticed (at night) when i get in the car and the key fob its with me that the orange light on the box lights up but no information its displayed inside.

Not sure what i should try next..

Thank you
 

·
2010 2.5 SL
Joined
·
588 Posts
You have lost me at "orange light on the box"; I'm not in my car and cannot visualize what you mean.

I'll try to remember to play around with my display this afternoon to replicate your situation.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #5 ·
correct the Control information box display backlight color its orange but the information inside the control box its not displaying.

i can see that the displays gets some power but dont understand why its not displaying the information.

thank you
 

·
2010 2.5 SL
Joined
·
588 Posts
I was unable to replicate your condition. Anything else on my end would be, at best, speculation and of no further use.
 
1 - 7 of 7 Posts
Top