The Nissan Club banner

1 - 10 of 10 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
i got a 2012 nissan altima 2.5 and i had a code for stepper motor. i just went ahead and change the whole valve body out and now its doing the same thing. does it require to be reprogrammed after you change valve body out?
 

·
09 Altima 3.5SE 6MT Sedan
Joined
·
5,547 Posts
'12's have CVTs and those don't have valve bodies...so what are you asking exactly? What Nissan Part No. did you 'change out'?
 

·
Registered
Joined
·
9 Posts
Discussion Starter #4
'12's have CVTs and those don't have valve bodies...so what are you asking exactly? What Nissan Part No. did you 'change out'?

part i change 2012 does have a cvt valve body assembly. pretty much simple question . after you change it out does it need to be reprogrammed because i think its in limp mode or something isnt going right on it
 

·
Registered
Joined
·
1,465 Posts

part i change 2012 does have a cvt valve body assembly. pretty much simple question . after you change it out does it need to be reprogrammed because i think its in limp mode or something isnt going right on it
Stop asking about it and have it reprogrammed! You have wasted too much time already....head to the dealer. What do you have to lose at this point?
 

·
Registered
Joined
·
9 Posts
Discussion Starter #6
dude tbh its simple question and money is tight at the moment. not a mechanic didnt know if you could do something and get out of limp mode or does it require to be reprogrammed? i mean if you aint going to help mine as well keep 2 cents to yourself bud .
 

·
09 Altima 3.5SE 6MT Sedan
Joined
·
5,547 Posts

·
Registered
Joined
·
1,145 Posts
We're talking about Versa but the issue is with Altima. The Altima uses the F09 or F10 trans in that year ('12) and the TSB (for the F11) does not apply to it. That F11 is the weird one with ROM inside the control assembly. Why the codes mentioned have mainly to do with the solenoids, the ROM instead of the TCM holds memory of them.

The two Altima transmissions mentioned do not have any ROM in the VB and should not need any reprogramming unless it has been lost, the VB change shouldn't do that.

The only thing needing any reprogramming would be a TCM change on those two units.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #10
sorry bud if it took m
We're talking about Versa but the issue is with Altima. The Altima uses the F09 or F10 trans in that year ('12) and the TSB (for the F11) does not apply to it. That F11 is the weird one with ROM inside the control assembly. Why the codes mentioned have mainly to do with the solenoids, the ROM instead of the TCM holds memory of them.

The two Altima transmissions mentioned do not have any ROM in the VB and should not need any reprogramming unless it has been lost, the VB change shouldn't do that.

The only thing needing any reprogramming would be a TCM change on those two units.
sorry bud if it took me a min to respawned was just out there burnin somebich down
 
1 - 10 of 10 Posts
Top