The Nissan Club banner

1 - 20 of 20 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
I bought a cold air intake, injen ,and I'm pretty sure I'm having maf problems. I have bought cleaner and used it properly, and it was fine for about 200 miles then it threw the code again. Any advice? Besides I put a CAI on an automatic, I put alot of highway miles on it.
 

·
09 Altima 3.5SE 6MT Sedan
Joined
·
6,121 Posts
Are you using an oiled filter...if so, STOP. This is a known issue.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #4
Actually I don't think so, the intake filter is designed to that specific intake setup. I'll order a none oiled filter, also should I even bother with the hydrasheild since I'm always on the road?
 

·
09 Altima 3.5SE 6MT Sedan
Joined
·
6,121 Posts
Depends how well protected your intake is...there are more than a few stories of hydrolocked CAI Nissans, I wouldn't remove it:


As for the oiled filter


 

·
Registered
Joined
·
10 Posts
Discussion Starter #6
Update I haven't touched it after cleaning it with the check engine light on, "which has been almost 5 days" ,leaving work today the light was off and I stopped for gas about 20 miles away and when I went to turn my car back on the light shows back up. It's an injen cold air intake system.
 

·
09 Altima 3.5SE 6MT Sedan
Joined
·
6,121 Posts
Let's see how you get on with a 'dry' filter and a re-cleaned MAF.
 

·
Registered
Joined
·
1,306 Posts
X2, the filters new sometimes have too much oil in them but impossible to measure that, the engine can sometimes suck off the excess which then pollutes the MAF wire but after the suck off the engine may go back to running right if MAF is clean. Can't be any air leaks there not even the slightest. And if the new setup changed the airflow around the MAF location then it may be unfixable, that reading is taken at a place specifically made for it, moving them around can make them unuseable.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #9
Update so I should mention the Injen cold air I take is a( sp1969p order #) and I just got the hydrasheild in the mail today. So far I've cleaned the MAF every 2 days when the light comes on and I'm going to put the hydrasheild on today and see what happens.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #10
Welp it's been 1 day and the light came back on, now probably the MAF is f'd because I have sprayed it so many times, auto zone its 145$ amazon its 21$ probably will be a week before I get it but I just wish someone knew about b16 sentras
 

·
09 Altima 3.5SE 6MT Sedan
Joined
·
6,121 Posts
did you ever get a non-oiled filter?
 

·
09 Altima 3.5SE 6MT Sedan
Joined
·
6,121 Posts
I noticed from Injen's site that the CAI has the MAF mounted vertically downwards--was OEM side mounted like my Altima?


A change in mounting position may cause strain on wires, or allow water/condensation to collect in the connector. MAF is a very weak signal. Check harness and connector, and consider spraying all electrical parts with silicone lube as a water repellant. Check you aren't getting mechanical interference with hood lining above...etc etc.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #15
Yes that is the exact one I got! How sensitive are the MAF? Like before I got the hydrasheild for the filter I think possibly may have been getting water sucked up in the filter, because I can put 3 fingers in a hole directly underneath the CAI. And me spraying it every 2 day for a month with MAF cleaner right after I've noticed the MAF silver part is starting to turn white as if its dissolving.
 

·
09 Altima 3.5SE 6MT Sedan
Joined
·
6,121 Posts
That wire shouldn't turn white, and it's pretty delicate. Did you say you'd ordered another MAF sensor? I think that is going to be your route to success. Although, we'll see how the $21 part performs....vs the $60 Hitachi OEM part

 

·
Registered
Joined
·
1,306 Posts
FYI, that filter says dry but the construction is like every other oiled filter on earth. You cannot zoom in enough to check if the medium is cotton gauze mesh but if it is it's supposed to oil.
 

·
Registered
Joined
·
1,306 Posts
That means literally NOTHING. Like manufacturing methods generally mean like manufacturing materials as well. You have a Chinese K&N filter copy there.

If the filter media is cotton gauze instead of paper then it's like no filter on engine at all, most dirt will go right through it.
 

·
Registered
Joined
·
1,306 Posts
1 - 20 of 20 Posts
Top