The Nissan Club banner

1 - 5 of 5 Posts

Registered
Joined
2 Posts
Discussion Starter #1
Was listening to music and radio started to sound distorted than the sound cut out followed by the radio cutting off with a burning smell and smoke coming from behind factory radio..no power to radio or back up camera after...changed fuse..radio and back up camera started working again but no sound..changed radio to aftermarket radio worked for a little but speakers didn't sound good..turned music up and sound went out again..does anybody know what could be causing this to happen..??? 馃槱
 

09 Altima 3.5SE 6MT Sedan
Joined
6,121 Posts
Sounds like one or more of your speakers is shorted out. Have someone test the resistance of each speaker coil...they are nominally 2, 4 or 8 ohms. I'm expecting you'll find one or more that are close to 0.
 

Registered
Joined
1,306 Posts
As said. previous radio fried and likely damaged speakers doing it. They in turn may have damaged the new radio.

Hoping not.
 

Registered
Joined
2 Posts
Discussion Starter #4
Sounds like one or more of your speakers is shorted out. Have someone test the resistance of each speaker coil...they are nominally 2, 4 or 8 ohms. I'm expecting you'll find one or more that are close to 0.
So I took the negative off of my battery for about 15 min when I put it back on I had sound from the speakers again ..that's was yesterday still playing today..can't turn it up as loud as I want because right passenger door speaker sounds distorted when turned up .. overall speakers sound terrible when turned up..they may be the problem馃様
 

Registered
Joined
1,306 Posts
You have to pay attention with the new radio, some demand a different ohm of speaker than what was in the car and not doing that can be trouble too. Speakers are commonly marked with the rating on them and they match to what the new radio calls for.
 
1 - 5 of 5 Posts
Top