The Nissan Club banner
1 - 1 of 1 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
I took my S model, 46,000 miles on the odo, no codes set in the ECM, on a long cross country trip up through Texas into Kansas. The long part was a sold 4 hour journey with 3 hours in rain. Now I get into Tulsa Oklahoma from about 200 miles oh running 75MPH on turnpike and it backfires through the exhaust. It sounded like it had crushed a can, then kicked it off the tire. No money lights, no indications of malfunctions. On stopping and turning at a light, we start smelling fuel through the AC vents (set to accept outside air, no recirc), it would grow stronger when we accelerated. We pull over to see about it, but could not find any leaks or outstanding odors under the hood or in the back. We take off again, and three city blocks at 35MPH we get a weak fuel odor again. We get it to the local dealership (Jackie Cooper Nissan Tulsa, FTW) and they went over it with a fine-tooth comb, even yanking the back seat out to peek at the fuel pump and plumbing, but nothing was found (they updated my radio's firmware too, YAY!). We were apprehensive about driving it, but the rep assured us. Since then, no issues or fuel smells were detected.

What would cause the backfire though? My thought it could have been the long drive plus the massive rainfall we had (the front collision radar glitched 2 or 3 times during the downpours we drove through) and caused the converter to cool off. What are your thoughts on this? No codes or flags are set in the ECM at this time.
 
1 - 1 of 1 Posts
Top