The Nissan Club banner
1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Today I installed a new Pioneer receiver. I replaced the Bose radio that came with the car.
To remove the factory radio, you must first remove the 3 air vent above the radio. In doing so, the wires for the hazards and passenger side airbag disable light, are very short, so I unplugged it. After the new receiver was installed, airbag light, hazard, and air vents all put back together, there is a problem. The passenger side airbag light comes on for about one second, then turns off(even if someone is in the seat). Then an airbag light on the dash blinks. Everything else works.
I noticed on the back of the factory radio there are four harnesses. One is antenna and one for power and audio signals to the amp. Now there are two harnesses not used. A square one with 8 pins and a rectangle one with 12 pins. I'm assuming one of them operates the steering wheel contols, but I'm clueless to the other one.
The new Pioneer works great and sounds really good. But did I cause the airbag problem by taking out the old radio? I never heard of an airbag circuit running through a radio before. In some Hondas you'll lose your dome light if you put in a new head unit. Any other place to look to find my problem?
2008 Altima 2.5 SL.

Thanks,
Tom
 

·
Remi 12 - 2.5SL
Joined
·
90 Posts
I had the same problem when I had an aftermarket unit installed in my 09. The problem was caused because the airbag light was unplugged and then at some point (when testing the radio of course), the power was turned back on. The shop that did my radio had a dealer do a reset at no charge to me.
 

·
09 Altima 3.5SE 6MT Sedan
Joined
·
6,365 Posts
You just have to clear the ABS code generated from powering on the car with that vent assembly unplugged. There's a (free) pedal dance to do so, vaguely it is:
turn on ignition, ABS light goes on for 2s, then it goes off..at which point you switch ignition off. Repeat for 3 cycles, and on the 4th with foot on the brake, start the car when the ABS light goes off. I'm pretty sure I posted this somewhere here already. Can't use OBDII readers to reset it. And yes, I did the exact same thing when I did my BOSE upgrade in my .sig below.
 
1 - 3 of 3 Posts
Top