The Nissan Club banner
1 - 13 of 13 Posts

·
member
Joined
·
140 Posts
Discussion Starter · #1 ·
i tried to connect the indiglos again, they still dont light up. i touched a wire to the dimmer switch control and now all of my lights on my dash dont work, the speedo, the heat-cool controls, gear shifter, what do i need to fix it? cuz i cant drive at night.
 

·
Registered
Joined
·
18 Posts
Possible answer

It should be a fuse. If not you may have fryed the inside of the dimmer button. If thats the case you can get another one @ a junkyard for little or nothing. You may need to check all the fuses having to do with lighting!!
 

·
member
Joined
·
140 Posts
Discussion Starter · #7 ·
95-xe, your right, the tail lights and front corner bulbs are not working, i changed the fuse inside the engine bay, that read "tail light" now my tails and corners are working. but my dash will still not light up, this sucks cuz i am going out tonight!
 

·
member
Joined
·
140 Posts
Discussion Starter · #9 ·
did you turn up the dimmer? Maybe you rolled it down by accident

thats exactly what i did, my bad. everything is workin fine now, thank you so much for the help 95-xe.
now if i can only get the ****in indiglos to glow! they blow.
had them workin for 5 months then they stopped. they come on once in a while.
 

·
Alty Go Boom
Joined
·
73 Posts
c-bo said:



thats exactly what i did, my bad. everything is workin fine now, thank you so much for the help 95-xe.
now if i can only get the ****in indiglos to glow! they blow.
had them workin for 5 months then they stopped. they come on once in a while.
might be a bad ground that can cause them to light on and off sometimes try regrounding them
 

·
09 Altima 3.5SE 6MT Sedan
Joined
·
6,365 Posts
check the dash lighting dimmer control.
 
1 - 13 of 13 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top