The Nissan Club banner

1 - 15 of 15 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1
wasup guys... I know the alternator problem/question is pretty popular around here....... anyways i posted(and searched) here a couple months back about my break light and battery light comming on at the same time and sure enough it was the alternator like you guys said. So i replaced the alternator and everything was well for a couple months untill TODAY!! Those same lights came on AGAIN!! Only this time, the break and battery light seem to stay on steadily whereas the first time it only seems to come on flickering on and off when i step on the accelerator. Has any1 here had this problem?? Is it really the alternator AGAIN?? Like i said the light now stays on instead of flickering like last time so i'm not really sure if its the same problem. Any help will be great... thanks guys!! btw, I have a 96 GXE.
 

·
Registered
Joined
·
318 Posts
the alternator maybe going. maybe you got a rebuilt altornator. get one from auto zone new and trade in the old one you will get a life time warrenty
 

·
Altimaboy
Joined
·
1,726 Posts
Don't get one from autozone. These are the remanufactured ones. If you want one that last, get one from nissan! It isn't that much more money, and you can save money by doing it yourself. It is right there on side of the engine.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #4
ALTIMA-125 said:
the alternator maybe going. maybe you got a rebuilt altornator. get one from auto zone new and trade in the old one you will get a life time warrenty
I got mine from pep boys(rebuilt) and it comes with lifetime warrenty. So is there no difference how the lights are comming on(Flickering light/steady light)??? Has any1 replaced their alternator with a rebuilt and had problems?? thanks for the help!
 

·
The Don.
Joined
·
6,151 Posts
Maybe I am the only one that subscribe to the idea that these alternators must be dieing because of something else causing them to go bad. All I know is that my stock alternator is 10 years old and still running strong. Maybe OEM is the way to go.
 

·
Altimaboy
Joined
·
1,726 Posts
jserrano said:
Maybe I am the only one that subscribe to the idea that these alternators must be dieing because of something else causing them to go bad. All I know is that my stock alternator is 10 years old and still running strong. Maybe OEM is the way to go.
Ain't this what I said? :confused:
 

·
Registered
Joined
·
163 Posts
kinda off subject, but doesnt MSD make a universal hi output alternator? that would be nice
 

·
Banned
Joined
·
1,045 Posts
Most likely the difference in lights is that the alternator is putting out less than maximum charge and it's not in as bad of shape as it was the last time you replaced it. You can talk to Steve at www.mralternator.com. Great guys to deal with down there.
 

·
holy s#!t
Joined
·
121 Posts
had mine rebuilt twice.went bad both times within 2 weeks.finally went to advanced and got one.no more probs.if you put it on yourself make sure you dont torqe to much.will burn it up.
 

·
Registered
Joined
·
318 Posts
well after my OEM 10 year old alternator died i got an autozone one and havnt had any problems with it
 

·
Registered
Joined
·
774 Posts
SexyGXE said:
Don't get one from autozone. These are the remanufactured ones. If you want one that last, get one from nissan! It isn't that much more money, and you can save money by doing it yourself. It is right there on side of the engine.
Nissan alternator is probably remanufactured also.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #14
thanks for the quick reply guys...well it was my alternator AGAIN.... it died on me yesterday and i was forced to replace the alternator in a near by parking lot. any1 know how tight the belt is suppose to be?? I kinda just went with my instincts on it yesterday...... anyways i'm going to take my car to a shop for a electrical test....to see if it'll tell me what is killing my alternator.... i'm thinking is my battery cable because it corals a lot!! anyways...wish me luck guys...

peaCe
 

·
Registered
Joined
·
13 Posts
Discussion Starter #15
ALTIMA-125 said:
well after my OEM 10 year old alternator died i got an autozone one and havnt had any problems with it
how long have u had ur autozone alternator in ur car?? thanks..
 
1 - 15 of 15 Posts
Top