The Nissan Club banner

1 - 9 of 9 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter #1
Need Help with Altima. Low RPM's feels like the car hesitates. High RPM's its runs smooth. Had tune up , New plugs NGK platinum , had injectors cleaned , tranny fluid flushed out and cleaned , new fuel filter. Please help.
 

·
Registered
Joined
·
1,701 Posts
this sucks, but i don't know what it could be. my suggestion is take it to the dealer for a diagnostic. don't let them fix anything though. just make sure they know exactly what the problem is, pay them for their diagnosing service, and then get the work done elsewhere.
Jay
 

·
Turbo S13
Joined
·
500 Posts
Altima94 said:
Need Help with Altima. Low RPM's feels like the car hesitates. High RPM's its runs smooth. Had tune up , New plugs NGK platinum , had injectors cleaned , tranny fluid flushed out and cleaned , new fuel filter. Please help.
put a can of "gumount fuel injector clearner" in a 3/4 tank of gas and take it out to the inter state and run that bitch to clean the injectors that should help. I had the same problem now I have sweet idle rpm of 600 never drops under that.
 

·
dismember
Joined
·
9,414 Posts
600 idle? man it feel so rough @ that rpm. i set mine @ 800. :)
 

·
dismember
Joined
·
9,414 Posts
i have an auto also, i beleive the factory spec for idel is 800 thats why i set it @ there :)
 

·
Turbo S13
Joined
·
500 Posts
chiadog said:
i have an auto also, i beleive the factory spec for idel is 800 thats why i set it @ there :)
factory spec is 600-700 . 900 when warming up.

look on the tag under your hood. or in your hayes manual
 

·
dismember
Joined
·
9,414 Posts
*shrugs* i am happy @ 800 :D engine feels too rough any lower :cool:
 
1 - 9 of 9 Posts
Top