The Nissan Club banner

1 - 5 of 5 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter #1
I noticed the sound about a week ago and the best way to describe is as i higher the fan speed I hear a loud whining helicopterish growl from the vents. Changed the cabin filter and no difference. I decided to remove the glove box this morning so I can take out the blower fan and take a look inside. Well I found the culprit which was a single leaf inside the blower fan. The whole job took under 10 minutes. Easiest DIY I've done. Hopefully this helps other ppl with the same issue. Btw my car is 2009 2.5 SL.


Sent from my iPhone using Autoguide.com App
 

·
Registered
Joined
·
643 Posts
all it takes is a single leaf to distort the fans. glad u figured that out yourself. i get plenty of those at the dealership and i wish all nissans were as easy as the altima. on rogues, versas, and sentras, the dash has to be pulled in order to access the blower motor GG


Sent from my iPhone using Autoguide.com App
 

·
Registered
Joined
·
104 Posts
Mine is doing the same thing and I was about to take it to the dealership since it's a 2012 with only has 6k miles, but I will check the fan motor to save me a few wasted hours of my life!
 

·
Registered
Joined
·
16 Posts
Discussion Starter #4
Mine is doing the same thing and I was about to take it to the dealership since it's a 2012 with only has 6k miles, but I will check the fan motor to save me a few wasted hours of my life!
A Phillips screw driver, 11 screws and roughly 10 minutes. That's all. Good luck.


Sent from my iPhone using Autoguide.com App
 

·
Registered
Joined
·
1 Posts
I noticed the sound about a week ago and the best way to describe is as i higher the fan speed I hear a loud whining helicopterish growl from the vents. Changed the cabin filter and no difference. I decided to remove the glove box this morning so I can take out the blower fan and take a look inside. Well I found the culprit which was a single leaf inside the blower fan. The whole job took under 10 minutes. Easiest DIY I've done. Hopefully this helps other ppl with the same issue. Btw my car is 2009 2.5 SL.


Sent from my iPhone using Autoguide.com App
Mine is doing the same, but it started doing it after I exchanged the blower motor and the resistor, I don’t know what’s the problem, might be a leaf but I’m most certain that that’s not the problem
 
1 - 5 of 5 Posts
Top