The Nissan Club banner

1 - 4 of 4 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1
Short version: 95 Altima 2.4, car stalls one night, starts after a few attempts, idles, moves under 5mph, stalls, restarts...towed home. Next day, wont start. Pull engine code, says Camshaft Position Sensor. Replace Distributor, car will start with some gas pedal feathering, but wont run on its own, it will run rough if revved over 3k. SES light came on, now it says Crankshaft Position Sensor.

Now here's the extremely odd part...the car would run great when I held my hand rather gently over the distributor, cupping all five wires in my hand (not really enough pressure to move the distributor, just lightly grasping the wires), but if I take the hand off, it stalls, hand on again idles smoothly at 800ish Rpm...so I changed the ignition wires, thinking this might have something to do with it, but now its the same thing.

The only other thing I can think that was weird is where the harness plugs in to the distributor, the retaining clip is broken (but i believe it was this way when I bought the car, and for the months it drove perfectly)...fidgeting with the harness had minor effects on the idle, but seemed to be independent of the wire fondling.

Anybody have any ideas? If I can't fix this rather cheaply myself, I'll have to give up on the car and move on.
 

·
Registered
Joined
·
11 Posts
Discussion Starter #3
Its not the harness, but thanks for the idea. If it's electrical interference, that would be over my head I fear.
 

·
Registered
Joined
·
4 Posts
If placing the hand on it helps, im thinking a bad contact and possibly the vibrations are reduced by placing the hand which in turn helps making the contact.
What i would do is check the continuity, if possible, in all wires going in the distributor.
I'd remove the dist. cap and check for anything broken inside, or loose.
Maybe replace it with a good known unit.
When you say you replaced it, was the new one, new, used, a known good unit? I've had used things come into my hand with the exact same issue that i had.
 
1 - 4 of 4 Posts
Top