The Nissan Club banner

1 - 13 of 13 Posts

·
Registered
Joined
·
81 Posts
Discussion Starter #1
Hello Team
I want to find where I can locate the can communication module/ line/ wires in my Nissan Sentra 2008 base 2.0l
Thanks

Sent from my SM-J700H using Tapatalk
 

·
09 Altima 3.5SE 6MT Sedan
Joined
·
5,753 Posts
They are everywhere...radio, cluster, transmission, ecm, abs.... What specifically are you trying to do?
 

·
Registered
Joined
·
81 Posts
Discussion Starter #3
Do we have a unit that combine all the wires into one module.
Undestand the can lines are H and L

Sent from my SM-J700H using Tapatalk
 

·
Registered
Joined
·
194 Posts
Do you mean the OBD port?
 

·
09 Altima 3.5SE 6MT Sedan
Joined
·
5,753 Posts
Do we have a unit that combine all the wires into one module.
Undestand the can lines are H and L

Sent from my SM-J700H using Tapatalk
Have a look at the LAN section of the FSM (for my '09...just to give you an idea)
 

·
Registered
Joined
·
1,218 Posts
If anything the ECM is the one unit but the TCM and BCM send and receive CAN as well, EVERYTHING pretty much uses the H and L lines, they are all over the car.
 

·
Registered
Joined
·
81 Posts
Discussion Starter #8
If anything the ECM is the one unit but the TCM and BCM send and receive CAN as well, EVERYTHING pretty much uses the H and L lines, they are all over the car.
So the Can is not a separate unit in the car like TCM, BCM or ECM right? It just interconnecting electric communication lines spread over the car ?

Sent from my SM-J700H using Tapatalk
 

·
09 Altima 3.5SE 6MT Sedan
Joined
·
5,753 Posts
You got it! It's basically the car's 2-wire serial communication network....so the ECM can tell the gauge what RPM the engine is at, or the BCM can tell the IPDM to turn on the headlight relays....etc. Some cars have multiple CAN networks (ie segmented, not one long chain)
 

·
Registered
Joined
·
81 Posts
Discussion Starter #10
So as per the picture attached, at the "Possible Cause" what does it mean by harness or connectors line open or shorted?
Which specific line (s) ??


Sent from my SM-J700H using Tapatalk
 

·
09 Altima 3.5SE 6MT Sedan
Joined
·
5,753 Posts
You have a wiring fault. Based on what module(s) are reporting this, you can identify which harness they are using and all modules attached to that harness. You can then disconnect all modules and then do continuity test, end to end and/or each module to end. 9 times out of 10 it's a connector corrosion or wiring fault at the connector due to flex.
 

·
Registered
Joined
·
81 Posts
Discussion Starter #12
You have a wiring fault. Based on what module(s) are reporting this, you can identify which harness they are using and all modules attached to that harness. You can then disconnect all modules and then do continuity test, end to end and/or each module to end. 9 times out of 10 it's a connector corrosion or wiring fault at the connector due to flex.
Based on P0500 (Vehicle Speed Sensor)
Read it on other forums that bad grounds can cause this code U1001 and U1000
What do you think about that
Btw the Speedo works flawlessly but when checked with obd2 it's seen as car is being driven vss stays 0km which is abnormal, thereby Ecm tripping the code P0500

Sent from my SM-J700H using Tapatalk
 

·
Registered
Joined
·
81 Posts
Discussion Starter #13
This is solved
Was the ECM, the one earlier installed was meant for the trim that has abs in it, but mine didn't have it so I got ECM that works with normal brakes and carries it's speed pulses from the speed sensor but not the abs module

Sent from my Redmi 4X using Tapatalk
 
1 - 13 of 13 Posts
Top