The Nissan Club banner
1 - 13 of 13 Posts

·
Girl-Moderator
Joined
·
1,127 Posts
Discussion Starter · #1 ·
Car is starting up slow, it's taking like 2-3 cranks to come on but the lights dim, the indiglos dim...sounds like it just has enough juice to crank over, but it does come on. Also when you hit the alarm, the "chirp" sounds quieter, like you can tell it doesn't have the regular amount of juice it should. Think it's just the battery? or more?
 

·
was up
Joined
·
2,392 Posts
prob just the battery. check the water in the cells and see if its up to normal, the water helps it charge and keep the charge. if its not that, then maybe its time for a new battery. how old is it?
 

·
Girl-Moderator
Joined
·
1,127 Posts
Discussion Starter · #6 ·
are they online? or here in town?>

Kenshi, and yeah, my bf cleaned the posts with that wire bristle
brush and cranked the cables down again. other thoughts?


98se said:
Av-
If new battery is needed, Costco has the optima red top for only $99. Just looking out...
 

·
Girl-Moderator
Joined
·
1,127 Posts
Discussion Starter · #13 ·
cool, we just got back from Autozone and the battery is only
marking 10.7 volts. they say they need 12 volts to test it.
Jerry is gonna take it back tomorrow and have them charge it
to test it. If it comes up bad, we'll get the Optima. Thanks.

98se said:
yep its 750cca
 
1 - 13 of 13 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top