The Nissan Club banner

1 - 10 of 10 Posts

·
*Horny Member*
Joined
·
743 Posts
Discussion Starter #1
It's 12:30am, I get home from the movies, and realize I have to return some videos before noon tomorrow (I like to sleep in). So, literally 5 minutes after I come in, I get in my car and turn the key. Nothing. Not even a crank. Apparently the battery is dead. The headlights still work, so does the stereo, but I guess it doesn't have enough juice to crank the engine. I added some distilled water to the battery, because it was really low. The light inside the car got brighter, but still nothing. Do I just need a jump and let the alternator charge for a while, or is my battery dead?
 

·
:-)
Joined
·
2,049 Posts
same thing hppened to me, i had to get a new starter motor :mad: its like 300$+(canadian)
 

·
VTEC wont save you....
Joined
·
6,411 Posts
Same thing here a few weeks ago.Check your battery connections.Make sure there is NO corrosion.I went to AUTOZONE and everything was fine.The guy sold me a terminal cleaner and some conductive grease to protect the terminals.Havent had a problem since.AUTOZONE will check your battery and ALT for free.

Hope this helps u out..

HK-
 

·
Cube Farmer
Joined
·
2,202 Posts
Starter motor if everything else still has plenty of power (like if your headlites dont look dim).
 

·
I Don't Drive An Altima
Joined
·
1,083 Posts
Try this if your car is a auto. It may sound stupid but mycar does it sometimes. Turn the key to accessory and move the car to the Netural positon, make sure the emergency brake is pulled up!!! Now try to start it. My car fucks up and doesnt start cuz it doesnt think it is in park or netural, some switch under it is messed up.
 

·
Official Troll
Joined
·
7,780 Posts
aaron1017 said:
Try this if your car is a auto. It may sound stupid but mycar does it sometimes. Turn the key to accessory and move the car to the Netural positon, make sure the emergency brake is pulled up!!! Now try to start it. My car fucks up and doesnt start cuz it doesnt think it is in park or netural, some switch under it is messed up.
It's not stupid. That happens to me sometimes. And it's mentioned in the owners manual that you can start the car in neutral.
 

·
Registered
Joined
·
6,377 Posts
autozone.com has a great trouble shooting "wizard". check it out.
Jae
 

·
Girl-Moderator
Joined
·
4,061 Posts
most likely it was just that the battery was low on water. the water is what allows the battery to store the charge. if it's been dry for a while, your battery could have gone bad. After filling it it give it a jump and it may or may not start. definately still take it to get checked. a battery low on water takes a while to get charged back up completely b/c it's lost quite a bit of it's reserve. the batteries tend to go low on water moreso during the summer b/c of the heat and the water evaporates a little more quickly. 99% sure it's just a low/bad battery.
 
1 - 10 of 10 Posts
Top