The Nissan Club banner

1 - 3 of 3 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
i was driving on the freeway and all of a sudden my battery and my break lights start to flash so i thought that my alternator was giving out. so i kept driving to see if my car gets me home, and as i press on the gas i hear a clicking noise coming from the engine, then my car stalls. so i merge to the right and i open my hood and their is radiator coolant all over my engine and the top of my radiator is cracked from one side to the other. i get my car home, install new radiator and my car wont start. it sounds like it wants to start but nothing. also when i try to start it coolant leaks from somewhere behind the heatshield. if somebody could help me out with this its greatly appreciated.thanks
 

·
Banned
Joined
·
117 Posts
Hi. You said: i get my car home, install new radiator and my car wont start.

Installing a radiator is a big procedure! Are you sure you didn't disturbe any wires? If you forgot to connect some harness back, it will not start.

Dry out the engine compartment really well, maybe use compressed air if u can find it, fill it up completely, start it up, (or turn the engine) and see what happens.
There should be no leaks anywhere.

If you still see something coming from behind the shiled ( u meant one that covers exaust manifold?), then the problem is there and u would have to remove shield for i nspextion. But it already doesn't sound good.

I would go from there...
 
1 - 3 of 3 Posts
Top