The Nissan Club banner
1 - 13 of 13 Posts

·
Registered
Joined
·
38 Posts
Discussion Starter · #1 ·
So I'm having problems starting up my altima.
It's a 2008 3.5 with 88k miles.

I did some research and at first assumed it was the brake switch since that seems to be a common issue with this car, but when I step on the brake pedal, the brake light turns on. I replaced it anyways just to make sure and still it doesn't start.

Another thing I want to point out is when I try to start the car, it skips over ACC mode and goes straight to ON and I can hear the fan come on but the car doesn't turn over.

I took it to Nissan and they're telling me they THINK it's the ECU and it's gonna cost over 1k to replace, but there's no guarantee that it's going to work. I'm not looking to pay a thousand bucks for something that might not work..

Any advice? Any help will be appreciated.
 

·
09 Altima 3.5SE 6MT Sedan
Joined
·
6,365 Posts
Steering column lock? Do you still hear the whirr whirr like some kind of air hatch unlocking when you press start?

Have a look at this thread even though the root cause is different..he did a tranny swap..the info and suggestions are all relevant. You'll need to check your PRNDL selector switch (aka PNP switch). You can probe the starter related relays in the IPDM to figure out where the start circuitry is breaking down...and then try to reverse why that is happening.

I'd bet 2:1 that it's a BCM issue (which controls the security aspects of starting) over ECM...but we need more info from testing/code reading etc.
 

·
Registered
Joined
·
38 Posts
Discussion Starter · #3 ·
Steering column lock? Do you still hear the whirr whirr like some kind of air hatch unlocking when you press start?

Have a look at this thread even though the root cause is different..he did a tranny swap..the info and suggestions are all relevant. You'll need to check your PRNDL selector switch (aka PNP switch). You can probe the starter related relays in the IPDM to figure out where the start circuitry is breaking down...and then try to reverse why that is happening.

I'd bet 2:1 that it's a BCM issue (which controls the security aspects of starting) over ECM...but we need more info from testing/code reading etc.
I don't think it's the steering wheel lock that's the problem but what do you mean by air hatch unlocking? I did hear a fan come on but thats it.

Right now the car is at Nissan so I can't troubleshoot/test it myself. They did a diagnostics test on the car and what's funny is that there are no codes or anything..
 

·
09 Altima 3.5SE 6MT Sedan
Joined
·
6,365 Posts
On 07-09 models, when the car enters start mode, there is a pause while an electric motor drives a locking ping out of the way of the steering column. These seem to jam after some time, and never send the security 'all clear' signal to the BCM which of course prevents the car from cranking.
 

·
Registered
Joined
·
38 Posts
Discussion Starter · #5 ·
I'm gonna get it towed home later this afternoon and take a look at it myself.

If it was the steering wheel column, would the start button have any functionality? I've noticed people with this issue, the start button wouldn't work at all. Just trying to clarify on this part.
 

·
Registered
Joined
·
38 Posts
Discussion Starter · #6 ·
On 07-09 models, when the car enters start mode, there is a pause while an electric motor drives a locking ping out of the way of the steering column. These seem to jam after some time, and never send the security 'all clear' signal to the BCM which of course prevents the car from cranking.
just got the car home. gonna check on everything you pointed out
 

·
Registered
Joined
·
38 Posts
Discussion Starter · #8 ·
Sorry guys, been busy with work.

So I have the car home and decided to poke around a bit to see if I can find anything. I noticed when I try to start the car, I get the yellow key light on the dash.



So what do you guys think? Steering wheel lock? or is it something else?
 

·
Registered
Joined
·
26 Posts
Have you tried inserting the key in the slot to the left of the steering column? When my 2008 2.5 S wouldn't start, the power would seem to try to come on and then click off immediately. Battery was dead, but this looks like a different problem. Try starting the car with the actual key instead of pressing the button.
 

·
Registered
Joined
·
38 Posts
Discussion Starter · #10 ·
Sorry guys been busy with work but finally found some time to work on the car today.

I recently found an ECU from a junkyard that matches my car that was pretty cheap so I figured I'd purchase it and try it out.

Just installed the ECU. Tried starting the car, it cranks up, but still won't start.

Any ideas?
 

·
Registered
Joined
·
38 Posts
Discussion Starter · #12 ·
Forgot to ask. If I swapped the ECU, do I have to get it reprogrammed or is it plug and play?

It came out of an altima that is the same year, make and model if that helps.
 

·
Altima FTW
ASE Certified Master Technician & Advanced Level Specialist
Joined
·
682 Posts
You need to get the ecu reprogrammed so the vin in the ecu matches the vin on the car.
 
1 - 13 of 13 Posts
Top