The Nissan Club banner
1 - 17 of 17 Posts

·
Registered
Joined
·
1,228 Posts
Discussion Starter · #1 ·
first off, white cars should have black engine bays:angry2:

now, I gotta now what I can do to clean up my engine bay, there's parts I can't reach and that are really dirty that degreaser won't clean up. I spent hours today trying to clean up my engine with no luck. How the hell am I supposed to clean all that without pulling the engine? Steam cleaning, pressure wash?

I have so much work to do on the engine, there's dozen's of metal parts I have to pull out to get them sandblasted and painted because of rust, damn canadian winters
 

·
Evil Member
Joined
·
374 Posts
me and my friend cleaned out our bays about a week ago and everything got cleaned, we went to the car wash and pressure washed everything first then we used some kind of brake parts cleaner and sprayed where we couldnt reach, then we rinsed everything off on high pressure, it works on most of it but there are a few spots that just got smeared, good luck, hope this helps;)
 

·
Registered
Joined
·
1,228 Posts
Discussion Starter · #3 ·
Thanks, I'll try that out. Now I have a major problem. My sister took the car out about 1 hour ago, after I washed the engine. Now she calls me and tells me the car is shaking in 1st and 2nd gear, and that it used 1/4 of the gas tank in about 30km(~20miles). WTF is wrong?!?! I didn't get a chance to look at it but I'm really worried. I sprayed about 1/2 can of engine finish on the engine after it dried I'm sure it's that but where could the problem be? Distributor, alternator?
 

·
Registered
Joined
·
1,228 Posts
Discussion Starter · #5 ·
yeah I covered the distributor, alternator and battery terminals. After I washed it, I went for a drive and everythings fine, then I came back, and sprayed engine finish on the engine, but when I did that I didn't cover anything, I was just careful where I sprayed it. If I got some on the distributor could that be the prob. and what could I do about it?
 

·
woohoo no longer a newbie
Joined
·
24 Posts
if you did that sux but doesn't seem like that should be too bad...you might want to check your plugs and make sure they are dry...also there is a problem sometimes with getting adapters wet...did you spray down over your intake if so you might have water buildup either in the intake or on the maf sensor and if so you need to dry that before it gets hosed..
 

·
Registered
Joined
·
1,228 Posts
Discussion Starter · #7 ·
ok I've been checking the car out for about an hour and a half. All spark plugs had water in them, the third one from the right had about an inch of water in it. The spark plug thread melted, so I can't take the plug out. I have to figure out how to take it out, I'm gonna pull the valve cover off someday.

Other than that though the car runs fine, once it dried up I took her for a spin and she runs like a champ. Next time I'm gonna check for water after cleaning before I start her up
 

·
Banned
Joined
·
0 Posts
that happened to my bro's car yesterday......I detailed it for the mofo, and I got water allll over the engine bay, except for the distributor and alternator. It shook like a mutha for about 20 mins, and then it was all fine.



Try Simple Green. Great stuff. ;)
 
G

·
i've never covered up anything in my car while hosing the engine bay down and i've never gotten water in the spark plugs or anywhere else, and my car has never shaken.
 

·
I am the universe.
Joined
·
1,034 Posts
rEvVoMaNiAc said:
i've never covered up anything in my car while hosing the engine bay down and i've never gotten water in the spark plugs or anywhere else, and my car has never shaken.

Well aren't you special? :rolleyes:
 

·
Shadetree Mechanic
Joined
·
2,228 Posts
Ya that sucks buddy. Im looking to take apart and repaint all under the hood as well. It's the salt from our Canadien roads!:angry2: Anyways....engine cleaner just won't cut it and will make your task of cleaning and preping for paint even worse. Take it where it hurts and rip it apart and paint all of it! You'll think it's worth it in the end..
 

·
Official Troll
Joined
·
2,695 Posts
I've had great luck with Prestone brand engine degreaser. Let the engine run hot. Spray. Close hood and let sit for about 15-20 min. Then open hood and gently hose.
 

·
H.N.I.C.
Joined
·
2,666 Posts
next time u get water in the spark plug holes just turn the car on ...
run awhile for minute to heat it up..
it'll knock n shake prob 'cause it's mis firing...
stop n turn it off..
n take the plugs out some...
the water will evaporate out..
if u don't take the plugs out the water jus condistates bak down n takes forever to get out....
 

·
Registered
Joined
·
141 Posts
just so you know brake cleaner is a NO NO NO NO it eats throught plastic if left on long time like 10 mins and if you don't believe me put a pair of plastic gloves on spray with brake cleaner and it will eat throught it. Just use like Simple Green and a spong with the green rough surface and you can get it looking like this and about the water in spark plug you sprayed way to long or you need new wires or they where no in all the way till the click oh here is a pic of mine and it is a 1994 with 127,000 and so clean if you wanted to eat off it you could but i don't:)
 

·
Registered
Joined
·
20 Posts
dont use oileaters

Me and my friend on his alty desided to use this stuff called oil eaters on his engine bay and it look like there was a film on it. the engine was hot when we did it. And when we hosed it off we got water in the # 3 and 4 spark plug holes. had to dry it out with cardboard. then his shit started to smoke out of the cd player i dont know what was up with that probably just a bad wiring job. but o well not my car. Any remedy for this plese help it looks like shit.
 

·
Registered
Joined
·
15 Posts
my car was shutting off when i washed . so i changed the spark plug wires distib cap and rotor. the cap and roto wasnt more than 20 bucks at auto zone if i remember correctly and i got the ngk wires and plugs from summet for 70 . i hope it helps your car
 
1 - 17 of 17 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top