The Nissan Club banner
1 - 14 of 14 Posts

·
f*cked up repugnant sh*t
Joined
·
7,745 Posts
Discussion Starter · #1 ·
would a clogged fuel injuection cause a car to skip occasionally at all speeds (it has done it idling at a light and at 65 on the highway and everything in between)? i am worried that it is somethin other than the injection (i hope it is that simple)....recently had a tune up and found no problems.....this started shortly after. yes, i have tried fuel injection cleaner.
????????

Image uploading. Refresh page to view
 

·
f*cked up repugnant sh*t
Joined
·
7,745 Posts
Discussion Starter · #4 ·
spark plugs all new, wires & etc.............at my tune up the distributor cap was checked.......could it be that tho??? (ug)
 

·
hard on equipment
Joined
·
714 Posts
I would suggest, in this order:
plugs (which you said are new, so that's not it)
wires
distributor
fuel injectors
fuel pump

and maybe describe the problem a little more clearly - when it "skips" does it make a sound, etc.
 

·
Registered
Joined
·
26 Posts
FYI: In the New York area there is bad gas going around.. there has been water in the gas causing cars to run like shit. Try adding Dry Gas and see what happens (additive from autoparts store) My car and a lot of other cars up here in buffalo are running real shitty.
 

·
Registered
Joined
·
2 Posts
You know I've noticed that shit too....my car just seems to bog down for no reason at aroung 2200-2600 rpms. I guess I'll give that dry gas a shot.
 

·
f*cked up repugnant sh*t
Joined
·
7,745 Posts
Discussion Starter · #10 ·
hey, thank you very much for the advice! i had a friend look at it last night and i think he might have fixed it......i hope!

Image uploading. Refresh page to view
 

·
f*cked up repugnant sh*t
Joined
·
7,745 Posts
Discussion Starter · #12 ·
some of the wires connecting the spark plugs were loose, and he tightened them ( i don't know enough yet about cars to have known that, ooops). i haven't drivin it too much since then but it didn't do it last night or this morning......i'm hoping......
 

·
Jr. Lord Of Search
Joined
·
1,507 Posts
Fette said:
some of the wires connecting the spark plugs were loose, and he tightened them ( i don't know enough yet about cars to have known that, ooops). i haven't drivin it too much since then but it didn't do it last night or this morning......i'm hoping......
that would do it!
 
1 - 14 of 14 Posts
Top