The Nissan Club banner
1 - 19 of 19 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hey guys, first time posting, from down in New Zealand. I have a first generation Altima (called a Bluebird here and in Japan) sr20det 5spd 4wd. The clutch pedal has started to give a creaky sound when pressed, which a lot of grease on the springs did not fix. Is this a common problem? :( Any ideas on how to fix it or at least locate the problem?
 

·
got widebody?®
Joined
·
1,546 Posts
Mine does that too...haven't figured it out yet though, the car's going back in on Monday. At least you know you're not alone. :D

P.S. You are a bastard. (sr20det) :D:D:D
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
Gr8 to know I'm not alone. If you get the problem sorted, could you drop me a line with the solution if possible? [email protected]. Thanks dude. There is apparently a common fault with Pulsar GTIR's, whereby the pedal box breaks free from the bulkhead or something, I hope it is not this. Good luck.
 

·
Jr. Lord Of Search
Joined
·
1,507 Posts
mine does too. i have yet to even look at it to figure out why. maybe tomorrow.
 

·
It's Paid For.
Joined
·
234 Posts
I had the same problem too. Don't ask me why but when I replaced the clutch and pressure plate the noise stopped. Mechanic said the pressure plate was going.
 

·
Registered
Joined
·
1,228 Posts
Mine used to do that. Sprayed some WD40, didn't help. I brought it to Nissan, they greased it up and since then I haven't heard a sound.
 

·
Jr. Lord Of Search
Joined
·
1,507 Posts
95_XE said:
Mine used to do that. Sprayed some WD40, didn't help. I brought it to Nissan, they greased it up and since then I haven't heard a sound.
how much to have it greased?
 

·
Die Trying
Joined
·
2,063 Posts
mine needed a new rod and bearing. I had pretty much the entire clutch assembly upraded and replaced when i did my clutch and flywheel. I mean new everything exept clutch master cylinder, that is it, well, and bell housing, but you know what i mean
 

·
Registered
Joined
·
1,323 Posts
Mine started squeeking at 149,000 miles. Thought it was the pedal but didn't see anythihg that needed greasing and I wasn't gonna spray wd40 cuz it would suck to get that on the pedal side and get all slippery.
I hope I don't need a new clutch...
Jay
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #17 ·
volume

Yeah, pretty loud, damn annoying in town.
 

·
stick shifter.
Joined
·
146 Posts
yeah, mine does it too. The sound has been there for over four years now. We got the clutch replaced and it didn't solve the problem. I'm not too worried about it now, kinda used to it too. But if someone comes up with the right solution on fixing it, i'll get it done.
 
1 - 19 of 19 Posts
Top