The Nissan Club banner
1 - 17 of 17 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 · (Edited)
2007 Altima driver and passenger power locks, passenger window issue

I bought a 2007 Altima 2.5 SL just over a week ago and I have not been disappointed with it, but there have been a few small issues that I want to take care of ASAP. After a few days I noticed the power locks on the driver's side not working, and not long after they stopped working on the passenger side as well. I can still lock and unlock the doors using the key fob. The passenger window switch stopped working recently as well, and for a while I could still open it from the master switch, but now that won't work either. All of the other windows work from both the door switch and the master switch as far as I know. Since some still work and some don't I'm not entirely convinced it's an electrical problem, but then again I have very limited knowledge on cars. The orange lights on the master switch are still on. From what I've read on other posts, some people have been able to fix this problem by taking the unit out and cleaning underneath the switches. What would a seasoned 2007 Altima owner suggest I do first?
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #2 ·
It may be worth noting that I did have the car inspected before buying, and they did not mention any electrical issues. The only non-cosmetic problems were a slow oil leak (or something to that effect) that I could wait 3 months or so to fix, and a broken tire pressure sensor. Of course, I'll have to check the documents they gave me to see if they even checked for any electrical problems or anything involving the power locks and windows.
 

·
Registered
Joined
·
180 Posts
More than likely need to clean the contacts on the master switches - drivers door. I had to do the same on my '08 right after I bought it used. There is a link either on this forum or another Altima forum that I used to learn how to remove the switch to clean it. It's a tedious job, but everything works just fine now.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #4 ·
Thanks, I was leaning towards trying that first but wanted to get a few more opinions. What did you use to clean them?
Also, do I need to do the same with the switches on the passenger door?
 

·
Registered
Joined
·
180 Posts
I used electronic spray - it is safe for all electronics, circuit boards, switches, etc. Can't recall what the name is, but you spray down all the switches once you have it apart and let it air dry. I did not have to do anything with passenger side.
 

·
09 Altima 3.5SE 6MT Sedan
Joined
·
6,365 Posts
@nismopc is right on the money...it's the master switch unit that is failing...happened to me. Now I caught it before I took possession so the dealer fixed it, but you can get them pretty reasonably on Alibaba...
 

·
Registered
Joined
·
34 Posts
Kinda the same thing with my recently bought 09 Altima SL. The master switch would not roll the rear passenger side window back up and the passenger side window was very sporadic. Sometimes it would work and other times it wouldn't.

I took the master switch out and took it apart and used electric contact cleaner on the switches and blowed them out as best as I could with caned air. The rear window works fine now but the front window still is isn't working properly.

Luckily I called the guy I bought it from and he was nice enough to order a new switch.

Good luck
 

·
09 Altima 3.5SE 6MT Sedan
Joined
·
6,365 Posts

·
04-05 Pedal Insert
Joined
·
5,767 Posts
That seems like a good deal. Did any of you try any of the reset procedures for the windows? I have had to do this on our Quest and they worked fine afterwards
 

·
09 Altima 3.5SE 6MT Sedan
Joined
·
6,365 Posts
In my case the switches didn't do anything..so no way to do the reset. Definitely the switches at fault. Replacement cured the issue...been almost 18 months now.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #11 ·
I'm having the same issue. I'm on a very tight budget right now so I'm going to try cleaning the switches before buying any new parts. Thank you for the advice!
 

·
Registered
Joined
·
14 Posts
Master Switch works fine

I bought a 2007 Altima 2.5 SL just over a week ago and I have not been disappointed with it, but there have been a few small issues that I want to take care of ASAP. After a few days I noticed the power locks on the driver's side not working, and not long after they stopped working on the passenger side as well. I can still lock and unlock the doors using the key fob. The passenger window switch stopped working recently as well, and for a while I could still open it from the master switch, but now that won't work either. All of the other windows work from both the door switch and the master switch as far as I know. Since some still work and some don't I'm not entirely convinced it's an electrical problem, but then again I have very limited knowledge on cars. The orange lights on the master switch are still on. From what I've read on other posts, some people have been able to fix this problem by taking the unit out and cleaning underneath the switches. What would a seasoned 2007 Altima owner suggest I do first?
The Master switch works fine on my 2007 Altima 3.5 SE. I replaced the passenger side switch and the DOOR lock stopped working. The door locks fine from the Master switch and the window goes up and down with the front passenger switch. Only the passenger door lock switch doesn't work. Any ideas. What two wires to check. see attached photo.
 

·
Registered
Joined
·
14 Posts
While cleaning the contacts on the passenger side front door lock, I noticed that both the lock and the window switch only work when the ignition is on, until it times out then they both become non responsive. I never changed the wiring, I replaced the switch. Is this the way it's supposed to work? If not, how do I fix that?
 

·
09 Altima 3.5SE 6MT Sedan
Joined
·
6,365 Posts
Mine only work when the ignition is on.
 

·
Registered
Joined
·
124 Posts
Just did this reset on my 08 and now my auto-up fuction works again. The procedure I used was just a tad different. According to mitchell on demand:

1. disconnect battery or window master switch for at least 1 minute
2. reconnect battery or master switch and roll window all the way down
3. roll window up with auto-up function and hold the up switch for at least 4 seconds after window is up

My windows were working fine, except the auto-up function. Auto-up works great now after the reset.
 
1 - 17 of 17 Posts
Top