The Nissan Club banner

1 - 19 of 19 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter #1
My wife has a 94 Altima. Only the driver side wiper is not working, it just lays there motionless( like some women I've known), while the passenger side wiper works fine. Is this something that is an easy fix, or should I leave it to a professional? I'm fairly handy with tools. Anyone else have this problem. the car is garaged so it's not frozen!!!!!. :confused:
 

·
your mom felt my length
Joined
·
1,077 Posts
Re: Re: Driver side wiper not working

TPhelps155 said:
I don't know the solution to the problem but that was a great first post with that line!:lol:
i already like this guy with that line...good job newbie...:D
edit: have you checked to see if the motor is working? any noises coming out of it like grinding or is it just dead?
 

·
Registered User
Joined
·
4,020 Posts
Since you say just your driver side arm is not moving, my first guess is the splines on the wiper arm or on the wiper bolt stud are warn and this is not allowing the arm to move. You can take the wiper arm off by removing a small plastic cap on the arm, then remove the nut holding it down. From there, push down on tha arm and slide the arm off the bolt stud. Check it over. Check the splines. If everything looks good, try your wipers without the driver side arm attached. See if the stud moves. If not, then it might be disconnected from the internal arm that is driven by the wiper motor. That is a little more difficult to diagnose, so I would try the later first, then if that doesn't work then, I'll explain the next step.
 

·
Registered
Joined
·
14 Posts
Discussion Starter #5
I'm a newbie here, but I'm a Vet on Maxima.org. The maintenace of the wife's car falls on me. I'll take a look at teh wiper tomorrow, too much rain for me to do it today. Thanks. I'll let you know the verdict
 

·
Resident drunken chef!
Joined
·
2,524 Posts
Same thing happened to my sisters alty, the arm fell off inside. They are hel on with little plastic cups, the cup wore out and it just fell off. We went to the junk yard and replaced it(the whole inside arm).
 

·
Resistance is futile
Joined
·
3,202 Posts
And to think there's people on here having trouble trying to disable one of their "wipahs" on purpose... :D
 

·
2003.5 g35 :)
Joined
·
417 Posts
may be the motor :p i dono if each wiper has a seprate motor.. if not.. its prolly the arm!
 

·
Import Tech.
Joined
·
4,670 Posts
Its probably just a loose nut on the arm ..Tighten the nut !!
 

·
Resident NICO Mod
Joined
·
5,972 Posts
SHAWN said:
Its probably just a loose nut on the arm ..Tighten the nut !!

I've seen this happen on frontiers a lot but on the altima...the wiper transmission is very flimsy and 9/10 times the link from the passenger to the drivers wiper transmission needs replacing.
 

·
Registered
Joined
·
14 Posts
Discussion Starter #12
I took the plastic cap and the nut off and inspected the connection. The threads on everything seemed to be in good condition. I turned the wipers on and the stud didn't move leaving me to believe there's a problem with the motor. The way it looks, I think it will be a pain in the @ss trying to get to it. It looks like you have to go in from under the dash somewhere.

My questions:

1) how difficult is it to change the motor?

2) how much for a motor?
 

·
Resident drunken chef!
Joined
·
2,524 Posts
No need to go under the dash, if onee wiper works, it is not the motor. you access the inner arm by removing both wipers, and all the plastic screws holding the black piece of plastic under the wipers down, you will then be able to lift it off, allowing you to see inside. you will most likley find an arm disconected.
 

·
Registered
Joined
·
14 Posts
Discussion Starter #15
You Da man Scoot, the linkage is not coonected. I tried connecting it but it wont stay together. looks like a little rust on the end too. do I need to replace the whole linkage?
 

·
Registered
Joined
·
14 Posts
Discussion Starter #19
I took out the old linkage now the trick is finding a salvage Yard near Albany NY that has the part. I called one place and they said they could have it in three days. with all the snow we've been getting, I don't know if I can go three days without wipers. I have RainX on the windows, but it doesn't help much with all the salt on the roads. I'll look around tomorrow too see if i can find one.
 
1 - 19 of 19 Posts
Top