The Nissan Club banner

Status
Not open for further replies.
1 - 5 of 5 Posts

·
Registered
Joined
·
622 Posts
Discussion Starter #1
I posted this in an already existing thread in the tire/suspension/etc forum, with no replies. I was hoping maybe people who post here, but don't read that forum could help. It's been a week, and I haven't heard anything.

I really thought people HAD put these on their cars as well, but I'm the only person i've seen having a problem putting it on.


I bought the 95-99 Maxima FSTB from ebay, and I tried to put it on my 99 SE... The holes for the bolts fit perfectly, but i couldn't get it on, cause crap from the engine was in the way. If i got one side bolted down, I couldn't even get the other side to touch down completely, since there was crap in the way, anyone have any clues?

Should I use washers/etc to raise it up, or.......?

Update: I checked my Haynes manual, and it's my EGR valve which is getting in the way.

Also, the strut bar doesn't go on the way i'd think. The 'C' braces where you bolt it to the strut bolts only fit one way. The way they fit, make the strut bar be in the 'front' vs every other picture of a strut bar, where they are in the 'back'. (I hope that makes sense)

Any help is appreciated :D
 

·
Registered
Joined
·
1,781 Posts
you use washers to bring it up a little bit from what i hear...
 

·
Registered
Joined
·
622 Posts
Discussion Starter #4
Matt-chu said:
should have just bought the proper strut bar
Wow thanks for the stroke of brilliance. I heard from many people that the maxima's strut bar would fit fine, and many people HAVE it installed. Only one other person had a problem, and that was just the bar rattling against the engine SOMETIMES.

If I knew then what I know now... I would have gotten the OEM one for my car.




tommymac: Yeah i heard that too, and i'm assuming that would be safe? or would that put weird torsion or something on the strut's bolts?
 
1 - 5 of 5 Posts
Status
Not open for further replies.
Top