The Nissan Club banner

1 - 16 of 16 Posts

·
Registered
Joined
·
54 Posts
Discussion Starter · #1 ·
Hey everyone......

I just got my car back from the repair shop because it would not start up...... and they said my engine was flooded. He said that it did that because of the mods that I have done......particulary the WAI. He said that it was screwing up my air/fuel ratio. I have a Ractive High Flow Intake. I was just wondering if anyone else has ever had this problem and what.....if anything......should I do about it. Are there any other add on parts I can get to fix this problem. Possibly a fuel pressure regulator? Thanks for the help.
 

·
i have a vtec(h) *phone*
Joined
·
267 Posts
people lie! get this through ur head mechanics lie more than everyone(sorry mechanics) but if u have done nothin to ur ECU that controls air/fuel the computer still thinks u have a factory air box. he was probaly messin' around skrewed up and blamed it on ur sh1ty ractive intake(i think thats what u have) if it happens again try a K&N filter if it will fit. maby ur breather has something to do with it, i dunno.
 

·
Registered
Joined
·
54 Posts
Discussion Starter · #3 ·
it was flooded when i took it in to the shop. It would try to start over but just wouldn't get going. This mechanic is very reliable and honest. My family has been taken our cars to him for the past 15 years and have never had a problem with him. When i first installed the filter i didn't know where to put the air filter box sensor so i put it in the original tube that feeds into the air box. At first the check engine light was on and then a few days later it magically shut off....don't know why. I have had this filter on for about 2 1/2 months with no problems either. Also....how would a K&N Filter solve the problem? Thanks
 

·
was up
Joined
·
2,392 Posts
yaggi482 said:
how would a K&N Filter solve the problem
it wouldnt


i dont think the intake would flood the engine. if anything it would run lean since theres more air comin in, not more fuel. first thing, try resetting your ecu and see if it starts up that way. if not, i suggest checkin the distributor cap and rotor and all that, the wires, sparkplugs etc.
 

·
Registered
Joined
·
2 Posts
my 95 started missing and flooding when it rained,so I went to auto zone and got some starter fluid and sprayed it in every time it wouldnt start. have you noticed if it was raining when this happened
 

·
i have a vtec(h) *phone*
Joined
·
267 Posts
K&N

it probaly wouldnt but the K&N is a better filter (I think) It's gotta be an ecu prob like the other guy said reset the ecu and good luck.
 

·
Banned
Joined
·
0 Posts
when I hear flooded, I think of too much gas......like starting the car with the gas pedal down until the engine has too much and will not start.

and if he said the car is flooded, I will assume that is the situation.....shouldn't the car start after the excess gasoline has evaporated, maybe 30 minutes later, max?
 

·
Registered
Joined
·
13 Posts
your car shouldnt be flooded. fuel-injected cars should rarely flood. if it is though, get a new O2 sensor, that might fix it. if not, u might be shelling out some dollars for new injectors cuz one or two or all of them may be stuck open. or it could be the fpr. no one on here could really know without looking at it. take it somewhere else and see what they say.
 

·
Registered
Joined
·
54 Posts
Discussion Starter · #9 ·
Thanks for all the help guys. Also...how do you reset the ECU?
 

·
Registered
Joined
·
217 Posts
hey,

yea if the engine flooded it would evaporate in a little and run just fine... trust me i did it when i shot too much nitrous while the engine was off trying to clear the line no problem now except for one cylinder isnt firing and i have yet to figure out why i think its the fuel injector
 

·
Registered
Joined
·
2 Posts
sounds like leaky injectors to me,does it flood when its been sitting for a while? mabee an 30 mins, if so the solution is to pull out injectors and have them cleaned, do not use injector cleaners i nthe tank
it won't work.

Trev
 

·
Registered
Joined
·
15 Posts
downhillracer: For new user of K&N filter of a stock car, it's a must to reset the ecu when we first use it. If YES, how do we do it? Thanks.:)
 

·
ItalianStallion
Joined
·
325 Posts
resetting the ecu only helps stuff. even if you car is stock it will just relign itself to the best setting it can find for everything that has changed over the years. I have never heard anyone say resetting the ecu ever hurt anything.
 

·
Registered
Joined
·
15 Posts
Domm: Appreciate your words of comfort. I'm pretty new to ECU. Would try to learn from more experienced owners from here..like you. Thanks.:)
 
1 - 16 of 16 Posts
Top