The Nissan Club banner

1 - 10 of 10 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hello everyone, I am new to the board, and have a question to you Altima Experts. I need help please... I have been having engine problems Missing, not running ect. Come to find out it was the Distributor, So I replaced the Distributor, dist. Cap, Rotor Button, Plugs and air filter. Car is still missing, I don't know if the timing is off or what. Any suggestions? Aslo, I notice to the right of my air filter (firewall side), there is a hose that comes up from the bottom of the engine, and hooks over and down (like a cane) and has nothing else on it, just a hose, no filter or other connections, I checked to see if it had vacume but nothing. Anyone know what this hose is for????? Any help will be apreciated greatly. Thanks.. Oh yeah forgot, 1994 Nissan Altima GXE. 5 speed.
 

·
Registered
Joined
·
3,570 Posts
Honestly, depending on where you got it, could be the distributor still, many have had recurring problems. Personally, I got mine from Autozone (Desperate and broke!) w/ LT warr and it has worked flawlessly for close to a year now. You can also check the ecu for trouble codes per the instrucs in the Haynes manual. Did you pull the plug wires to see possibly which cylinder(s) are not getting fire? Fuel filter been changed lately? Start w/ the easiest and cheapest options and go from there.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
niceguy. I got the dist. at Advance auto, I replaced fuel fitler about 3 months ago. I have not checked the plug wires, but I will this afternoon. Thanks for your help. Also to check the codes, does that have to be done at a dealer, or mechanic with the diagnostic computers?
 

·
Registered
Joined
·
90 Posts
I had the same problem I replaced the distributor with a one from autozone and it we bad within two weeks I brought one from Napa and it runs perfect now so check your distributor>
 
1 - 10 of 10 Posts
Top