The Nissan Club banner
1 - 4 of 4 Posts

·
Am I still a NOOB?
Joined
·
831 Posts
Discussion Starter · #1 ·
Question. I'm having a knock sensor prob with my car. I run 93 octane in it. I had recently gotten into an accident. I rear ended a montero sport. When that happened, the radiator basically looked like it exploded and was spewing coolant everywhere. I think some might have gotten into the alternator. After I picked my car up from the shop, it looked beautiful. Then I made a stop and came back out to my car a half hour later. I started it, put it into gear, and it shut off. I tried to start it, and it wouldn't start. It would just crank. Then I went back to the car two days later, and it started, but it wouldn't revv above 1k rpms. The check engine code told me it was the knock sensor that was the problem. A couple of other altimas.net members told me it could be the alternator. I just wanted to get some more opinions. Got any ideas?

-AltyPrince
 

·
Am I still a NOOB?
Joined
·
831 Posts
Discussion Starter · #4 ·
I know my shit. It's just that one of my other friends had the same problem, and he took it into that shop and it turned out to be the alternator, which I see is very wierd, but that was the case. And I know it's already happened to Altimeezy, twice, and it was his alternator both times. So I'm kinda confused here.
 

·
Am I still a NOOB?
Joined
·
831 Posts
Discussion Starter · #5 ·
Re: Re: knock sensor

kenshi said:
That sounds like a MAF sensor problem, not a knock sensor especially since your running 93-octane gas in an engine designed for 87.
I'm not challenging your knowledge, but how can it be the MAF when the engine code flashed 34, which is the knock sensor according to the list of codes I had?
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top