The Nissan Club banner
1 - 6 of 6 Posts

·
Registered
2010 Nissan Altima 2.5 S
Joined
·
2 Posts
Discussion Starter · #1 ·
I have a 2010 Nissan Altima 2.5 S and I went to Best Buy to have a full sound system install the works sub amp ect. When I picked up car will barley go over 65 mph if in neutral and floor it won't go over 2.5 RPM plus VDC Off light and check engine light was on after I got it back from best buy they said I brought it there like that my car was perfect until post install DOES anyone know or have a idea what they could have hit or shorted out to cause these problems??? I replaced few things throttle body gas pedal ect still can't figure it out
 

·
Registered
Joined
·
2,264 Posts
Unless you have the tools, ability, including an expensive scanner, and access to the Nissan Factory Service Manual or have access to ALLDATA....you will be "replacing a few things throttle body gas pedal ect still can't figure it out."

Your best bet is to seek professional diagnostic help, either the Nissan dealer or a trusted garage, to diagnose and repair your problem.

We can only guess what wires were cut/spliced/incorrectly hooked up by the craftsmen at the stereo shop.

My guess is that you will never 'get lucky' by replacing random parts.
 

·
Registered
2012 Nissan Altima 3.5 Coupe
Joined
·
3 Posts
Check all the ground wires for the car, especially for the new sound system - It could easily be a ground wire that has been pulled loose or disconnected by the audio installers. .You can turn off the VDC with a switch on your dash and this may temporarily restore power - but - you still have a problem. Read more about the VDC here: VDC The VDC is likely the culprit robbing your power. There is also a very crude way of resetting the ECU that might work for you, it is mentioned in a video 'included' in the link above. Please let us know if it works.
 

·
Registered
Joined
·
6 Posts
I have a 2010 Nissan Altima 2.5 S and I went to Best Buy to have a full sound system install the works sub amp ect. When I picked up car will barley go over 65 mph if in neutral and floor it won't go over 2.5 RPM plus VDC Off light and check engine light was on after I got it back from best buy they said I brought it there like that my car was perfect until post install DOES anyone know or have a idea what they could have hit or shorted out to cause these problems??? I replaced few things throttle body gas pedal ect still can't figure it out
My 3.5 did this coming back from SLC last year, except at 3k RPM. No lights came on, and I made it home eventually. 2 months later, my alternator was dead. So that is my guess, your alternator will be dead soon. Yours is fairly easy to replace as it is on top. 2010 Alternator replacement (YouTube)

Edit: Actually read the first part of the post lol. I'd make best buy double check all their work.
 
1 - 6 of 6 Posts
Top