The Nissan Club banner
1 - 3 of 3 Posts

·
Registered
Joined
·
88 Posts
Discussion Starter · #1 ·
The main question for this thread is Can a no EGR function (0400) cause random cylinder misfire (0300) and if so how exactly?

I finally understand how the EGR vacuum system works, or at least how to troubleshoot it and believe I am close to solving that 0400 code. No vacuum at EGR valve due to no vacuum across BPT ports due to no exhaust pressure sensed from port below BPT valve. I removed the BPT valve and hooked up a vacuum pump to one port and vacuum gauge to other. The gauge did not read any vacuum until I blew into the bottom port. However it doesn't hold steady; it slowly dies off. Is this normal here?

Anyways it looks like I have a clogged EGR tube to the BPT valve. Should I be able to clean it thoroughly without removing the throttle body? I cleaned this tube 8 years ago when I removed throttle body and intake manifold to replace intake manifold gasket. Don't remember what was necessary to clean the tube though.

To wrap up though, once I fix this EGR issue can I expect my misfire to go away? I am doubtful because the car feels worse on idle (especially with a/c on) and I don't think the EGR system affects idle, only open throttle condition; my thinking is the lack of a functioning EGR makes no impact at idle (where my car feels worse).

What do you think?
 

·
09 Altima 3.5SE 6MT Sedan
Joined
·
6,365 Posts
ok, I'll wade in on this one :)

Ten seconds of Googling found this useful article on P0400. Excerpt

"On many 90's and early 00's Nissan vehicles (e.g. Pathfinder, Altima, Maxima, Frontier, Quest) the code P0400 could be caused by a carbon buildup blocking the air flow around EGR temperature sensor. The repair involves removing and cleaning the EGR temperature sensor an the EGR tubes, ports and passages. A service bulletin for the 1998-2002 Frontier and Xterra with a 2.4L 4-cylinder engine recommends cleaning the EGR port in the intake manifold; the EGR port plugs need to be removed. "

I don't think the P0400 and P0300 are related. P0300 is more likely an intake leak, bad compression and/or worn/coked up plugs.
 
1 - 3 of 3 Posts
Top