The Nissan Club banner

1 - 14 of 14 Posts

·
Registered
Joined
·
84 Posts
Discussion Starter #1
I recently took some time out of my regular schedule to install some aftermarket custom speakers replacing my factory speakers....I replaced both door speakers with 5 by 7's and the back two speakers with 6 inchers...basically just doing a simple swap..."I just put in new speakers...it's gonna sound great"..so I'm all happy now and thinking to myself my stereo will sound a lot better now... so I throw in my xhibit cd ready to bump some bass...and they sound fuckin horrible...the door speakers are good but the back speakers put out flat hollow bass...I can't even listen to the fuckin stereo drivin down the road because the back one's sound so bad...I don't know what the hell I did wrong....the front speaker hand 150 watts and the back ones handle 130 watts...they are all pioneer by the way too....what the hell do I do??? Shouldn't the bass and sound be coming out better??? I don't get it....here I am trying to upgrade my system and all I did was make it worse....my factory speakers sounded better than these. I'm about to drive my motherfucking car into motherfucking brick wall across the road....someone help me please
 

·
Youngest OG Member
Joined
·
761 Posts
Maybe there's something wrong with the connection or maybe
it's the speakers,happen to me once,one of my rear speakers did not prduce bass just treble.I suggest ,look at the connection and the wires/harness and see if you screw down the speakers tight enough.Hope this helps.:D
 

·
Registered
Joined
·
84 Posts
Discussion Starter #4
I have all the speaker screwed in extra tight...the front one's seem to sound good but the bass in back just sounds horrible. I spliced all the wires correctly...should I just buy new speakers in back...what's polarity...and what would you do to fix it??? Right now I'm just at a loss....because the wire connection looks good and I can't think of anything else to do.
 

·
Registered
Joined
·
1,701 Posts
polarity is matching the positive wire to the positive terminal of the speaker. Make sure all speakers are connected correctly.
If you reverse 1 (neg to pos), and the bass bumps, one cone will be moving out and the other speaker's cone will be movingin, hence cancelling each other and you lose bass (and sounds hollow)
Can you post the model of front and rear speakers and the price u got them for? I'm looking for replacements for mine...maybe a slight upgrade, but I don't have tons of $.
Jay
 

·
Illest in Nebraska
Joined
·
1,168 Posts
Ok what kind of head unit do you have? are the speakers running off of that, or an amp? if off the head unit then did you adjust it? off of the amp then what kind of amp ?
 

·
Registered
Joined
·
84 Posts
Discussion Starter #7
alright...we may be getting somewhere....the wires in the back didn't have a line to separate positive from neg....

I just checked:

on the right side one is pink and one is blue...there are no lines on either wire

on the left side one is red and one is green ...also no lines on either side
 

·
Dreamer
Joined
·
665 Posts
Sounds like a polarity problem. The same thing happened to me. Its actually very easy to trouble shoot this problem. First set the fade all the way to the rear, then set the balance to one side. If the bass comes back, then its definitely a polarity problem. Check it out!
 

·
Illest in Nebraska
Joined
·
1,168 Posts
by adjust i mean set all your audio levels i.e. bass treble and all the other functions these damn things have now days, try their idea first. It might be possible that you aren't putting enough power to the speakers. between my head unit and amp my speakers sounded like ass on the head unit but on the amp they sound good as hell
 

·
de-moderator
Joined
·
1,545 Posts
www.installdr.com

Go there find the wiring diagram for the altima. I had the same problem with mine. Really good site for installing shit. I'd find the links for you but... well i am too lazy and my stupid DUN connection wont connect more than 26400 getting cable modem on wednesday. Then, i'll find the links fo ryou! Hope the install DR site helps!
 

·
Registered
Joined
·
84 Posts
Discussion Starter #14
fuck pioneer...I ripped those sons of bitches out and threw em in the fuckin road...then I went out and bought some clarions put those in the back and dynamated the rear deck....it sounds phat now....I'm just waiting on buying amp for my subs now.

Thanks for everyones help

later
 
1 - 14 of 14 Posts
Top